Bug 448132 - F9 kernel 2.6.25.3-18 update broke grub.conf
F9 kernel 2.6.25.3-18 update broke grub.conf
Status: CLOSED DUPLICATE of bug 446362
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 13:07 EDT by Antti Huhtala
Modified: 2008-06-02 10:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 10:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antti Huhtala 2008-05-23 13:07:33 EDT
Description of problem:
When updating the newly-upgraded (F8->F9) Fedora 9 system (kernel 2.6.25-14)
with 'yum update' in my dual-boot (Win XP & Fedora) x86_64 desktop box to kernel
2.6.25.3-18 and rebooting, the boot process stopped at a stage where only the
word "GRUB" was displayed on screen and the system loudspeaker kept on playing
'error' sounds. Ctrl-Alt-Del was able to stop that and reboot, but I never got
past the "GRUB" stage. Neither of the OS'es could be booted.


Version-Release number of selected component (if applicable):
I don't know. What is the anaconda version on the F9 DVD?

How reproducible:
Hard to say. This may be a hardware-specific problem or the result of upgrade
instead of clean install. It has happened to one other reporter on fedora-list
at least.

Steps to Reproduce:
1. Upgrade F8->F9 on an x86_64 platform
2. Update kernel from 2.6.25-14 to 2.6.25.3-18
3.
  
Actual results:
Booting stops at "GRUB" and rings system loudspeaker

Expected results:
Boot continues to a fully operational F9 system

Additional info:
I used the F9 DVD and its "Rescue" option. Checking grub.conf revealed that
(probably) anaconda had rewritten grub.conf to contain lines such as:

kernel /vmlinuz-2.6.25.3-18.fc9.x86_64 ro
root=UUID=ab562fb5-0a9a-4458-9f30-61c8a23f774a rhgb quiet

instead of the expected:

kernel /vmlinuz-2.6.25.3-18.fc9.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet

I replaced the "UUID=..." with "/dev/VolGroup00/LogVol00" using vi and rebooted.
Now both OS's *can* be booted but I wonder why my UUID ended up in grub.conf. I
can't figure out how it could be useful to GRUB.
Comment 1 Antti Huhtala 2008-05-25 00:25:17 EDT
I forgot to mention that *before* editing grub.conf I ran grub-install. I'm not
absolutely sure whether I tried rebooting after running grub-install but I
probably did - to no avail. However, after editing grub.conf and rebooting,
everything seemed to be OK.
Comment 2 Andy Lindeberg 2008-06-02 10:44:20 EDT

*** This bug has been marked as a duplicate of 446362 ***

Note You need to log in before you can comment on or make changes to this bug.