Bug 448166 - Boot hangs with Intel ICH9 SATA controller
Boot hangs with Intel ICH9 SATA controller
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 16:58 EDT by richard42k
Modified: 2009-07-14 11:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description richard42k 2008-05-23 16:58:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
I have suggested this is a kernel problem because I have a similar problem with Ubuntu.
I have a Dell Vostro 400 which has an Intel ICH9 SATA controller using IDE emulation.  I can run Fedora 9 both Gnome and KDE from live CDs with no problem, except that on loading from every Fedora CD (all of which have been checked) I get a number of buffer I/O errors on device sr0.  I have installed from the i386 DVD and from the Gnome live CD and cannot boot either.  I cannot boot from the Fedora 8 Gnome live CD, although following a suggestion on the Ubuntu forum I can boot from it if I change the SATA mode to RAID.  The problem seems to be with the hard disks.  It starts Disabling IRQ #19 (#18 in Fedora 8) and then has numerous messages about ata1.00 and ata2.00.  It starts at SATA 3Gbit/s and reduces to SATA 1.5Gbit/s and reduces from UDMA/133 to UDMA/100 to UDMA/33 but never seems to find a speed at which it is happy.

I have tried pci=noacpi but it makes no difference.

I can run OpenSUSE 10.3 both Gnome and KDE and both installed and from live CD without any problem.  Ubuntu 7.10 only boots installed or from live CD about one time in three.  Ubuntu 8.04 live CD will not boot at all, but it does boot if I change SATA mode to RAID, and Ubuntu 7.10 boots reliably if SATA mode is set to RAID, but that will not work with Windows and I understand it is not safe to change modes with data on the disks.  If I try to run the installed Fedora 9 Gnome with SATA mode set to RAID it cannot read the disks.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 9 from i386 DVD or install from Gnome live CD
2. Try to boot from installed version
3.

Actual Results:
Long pauses in boot process.  With quiet disabled, many more messages about ata1.00 and ata2.00

Expected Results:
Boot into Gnome desktop

Additional info:
Comment 1 richard42k 2008-05-27 13:24:13 EDT
I have now tried Fedora 7.  The live CD runs, although it does not recognise the
on-board LAN device.  The I/O buffer errors on sr0 also occur.  When I try to
boot after installing from the live CD I get
irq 18: nobody cares (try booting with irqpoll option)
Disabling IRQ #18
usb3-1: device not accepting address 2, error -71
ata1.00 failed to set xfermode (err_mask=0x40)

The last line is repeated 3 times, then the same for ata2.00 then for 3 and 4,
which don't exist, although the error mask is then 0x4
It ends up with something about a kernel panic, being unable to sync, and an
attempt to kill init
The messages failed to set xfermode also occur with Ubuntu.
Comment 2 richard42k 2008-05-27 14:31:27 EDT
Booting with irqpoll seems to be the answer.  I tried it with the Fedora 7 I had
installed from the live CD and it worked.  I have now installed Fedora 9 from
the i386 DVD and it has worked with that too.  In fact I am using Fedora 9 to
send this message.  Is it possible to update the kernel to avoid the need for
adding the irqpoll option?
Comment 3 Chuck Ebbert 2008-06-09 22:15:20 EDT
Some unknown device is spewing interrupts. When this problem happened on IBM
machines it turned out that a BIOS update fixed the problem. 'noirqdebug' should
work better than 'irqpoll' in the meantime...
Comment 4 huang shijie 2008-07-20 21:44:14 EDT
My vostro 200 has the same problem.
I even could not install the fedora 9 by the DVD.
Comment 5 Bug Zapper 2009-06-09 21:07:46 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-07-14 11:48:00 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.