Bug 448172 - Kickstart refuses to install group default packages if --nodefaults is specified for group
Kickstart refuses to install group default packages if --nodefaults is specif...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 19:26 EDT by Stephen Clouse
Modified: 2008-08-26 14:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 14:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Clouse 2008-05-23 19:26:49 EDT
I'm running numerous Kickstart installs of Fedora 9 final.  These are heavily
stripped-down minimal machines -- no X at all, anything GUI-related is left off.
 So the Kickstart files have very specific package lists.

One box is a development box, so the goal was to install the mandatory
Development Tools packages (all of which are needed), and then a select few
additional packages.  This part of the Kickstart file %packages entry looks like
this:

  @Development Tools --nodefaults
  elfutils
  cpan2rpm
  ltrace
  patchutils
  subversion
  valgrind

What ends up happening is, anything that is normally a default selection for
that group fails to install, even if the package was specifically named later
on.  It appears to handle the --nodefaults option last, and then removes any
package that is on the default list.

If you use the particular %packages snippet above, you'll get the mandatory
Development Tools packages (as expected), but it fails to install elfutils,
ltrace, patchutils, subversion, and valgrind.  All 5 of those are defaults for
the Development Tools group.  cpan2rpm, on the other hand, does get installed,
as it's normally an optional package.
Comment 1 Chris Lumens 2008-08-26 14:38:06 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.