Bug 448174 - monodevelop cannot find libgtkembedmoz.so
monodevelop cannot find libgtkembedmoz.so
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 20:28 EDT by Ben Liblit
Modified: 2008-09-12 04:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 04:38:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Liblit 2008-05-23 20:28:55 EDT
Description of problem:

monodevelop prints the following diagnostic output on startup:

    WARNING: Cannot find Mozilla directory containing libgtkembedmoz.so. Some
    Addins may not be able to function. Please set MOZILLA_FIVE_HOME to your
    Mozilla directory.

Version-Release number of selected component (if applicable):

monodevelop-0.19-6.fc9.i386

How reproducible:

100% reproducible

Steps to Reproduce:
1. run "monodevelop"
  
Actual results:

Diagnostic output as described above.

Expected results:

No diagnostic output.

Additional info:

I see a copy of the missing library in "/usr/lib/thunderbird-2.0.0.14", and the
diagnostic output goes away if I set MOZILLA_FIVE_HOME to this directory.  But I
shouldn't have to do this manually, and monodevelop probably shouldn't depend on
thunderbird anyway.
Comment 1 Paul F. Johnson 2008-05-27 07:05:51 EDT
It doesn't really make a difference to be honest in the operation of monodevelop
and to require thunderbird is a pain.

If you don't set it, does it cause a problem?
Comment 2 Ben Liblit 2008-05-27 20:20:55 EDT
I'm seeing a large number of launch-time error messages about add-ins that could
not be started.  Since the error message I described here states that "Some
Addins may not be able to function," I thought this might be the cause.  But the
add-in errors remain even if I set MOZILLA_FIVE_HOME to
/usr/lib/thunderbird-2.0.0.14, so perhaps that's an unrelated problem.  I'll
file a new bug report for the add-in errors.

As for this problem, well, if it doesn't cause problems then the warning message
itself is misleading.  If the warning is frivolous then it should be removed.
Comment 3 Ben Liblit 2008-08-08 01:36:27 EDT
A frivolous warning is a bug, but not a very pressing one.  Changing priority to "low".
Comment 4 Paul F. Johnson 2008-09-03 10:21:31 EDT
It's not even a bug to be honest as it's not required. That said, I'm going to see what happens with it in rawhide...
Comment 5 Paul F. Johnson 2008-09-12 04:38:25 EDT
Closing the bug - it's a warning that really has no effect on the running of MD.

Note You need to log in before you can comment on or make changes to this bug.