Bug 448189 - Window switching with Alt+Tab does not work
Window switching with Alt+Tab does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 03:50 EDT by Syam
Modified: 2008-09-07 23:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 07:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 162150 None None None Never

  None (edit)
Description Syam 2008-05-24 03:50:22 EDT
Description of problem:
After logging in to KDE4, Alt+Tab for window switching does not work. After 
repeatedly trying for 10-20 times, it starts to work. From that point onwards, 
it works flawlessly.

How reproducible:


Steps to Reproduce:
1. Log in to KDE
2. Open couple of windows- dolphin, firefox & opera
3. Try switching between windows with Alt+Tab
4. If that doesn't work, keep pressing Tab (+Alt) repeatedly until the small 
window list is shown and switching works.
  
Actual results:
Windows do not switch with Alt+tab

Expected results:
Windows switch with Alt+tab
Comment 1 Ngo Than 2008-05-26 05:00:27 EDT
Could you please try with a fresh new user? If it still doesn't work, you should
please update to KDE 4.0.4 which are available in F9-update.

I cannot reproduce this problem with 4.0.4 on my test machine
Comment 2 Syam 2008-05-26 05:24:30 EDT
Thanks for the response. I've already updated to KDE 4.0.4, and the problem 
persists.

I tried with a fresh new user:

1. Log in, open 2 dolphin windows
Alt+Tab seems to work, but there are some lags and misses. It doesn't switch 
sometimes, and sometimes it switches on a second tap on the tab!

2. Log in, open dolphin, then opera and then firefox
The same behaviour as the original bug report!
Comment 3 Todd J Martin 2008-05-26 10:03:02 EDT
I also see this behavior (with KDE 4.0.4).  I was using Alt-Tab to switch
between firefox and konsole.  The problem is intermittent.  I never knew when it
would fail, but sometimes when I hit Alt-Tab nothing happens.

Is there anything that users can do to help troubleshoot this?
Comment 4 Rex Dieter 2008-05-26 10:51:55 EDT
Fwiw, I've seen this happen exactly *once*, and once I started another app, it
went away and started functioning properly.
Comment 5 Steven M. Parrish 2008-05-27 07:57:59 EDT
Looks like this has already been reported upstream. 
http://bugs.kde.org/show_bug.cgi?id=162150   closing this bug in favor of the
upstream one.  Will monitor that one for updates.
Comment 6 David Tonhofer 2008-09-07 12:28:57 EDT
This annoying thing is still not working.


kdebase-4.0.5-5.fc9.x86_64
kdebase-workspace-4.0.5-3.fc9.x86_64


"Much anger in you. Patience, young one!"
Comment 7 Kevin Kofler 2008-09-07 12:33:57 EDT
We never claimed it was, the upstream bug report is still open.
Comment 8 Syam 2008-09-07 22:27:54 EDT
The bug is NOT present in KDE 4.1, updated from updates-testing on Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.