Bug 448190 - Bad VideoRAM size detection on KM400
Bad VideoRAM size detection on KM400
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
: Desktop, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 04:02 EDT by Prasad Dhanakodi
Modified: 2018-04-11 05:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 12:10:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora 9 Booting from DVD (1.26 MB, image/jpeg)
2008-05-24 04:02 EDT, Prasad Dhanakodi
no flags Details
Camera shot of KDE Live Desktop in my system (2.06 MB, image/jpeg)
2008-05-24 04:03 EDT, Prasad Dhanakodi
no flags Details
X Server Config File (/etc/X11/xorg.conf) (570 bytes, text/plain)
2008-05-26 14:53 EDT, Prasad Dhanakodi
no flags Details
X Server Log File (47.14 KB, text/plain)
2008-05-26 14:54 EDT, Prasad Dhanakodi
no flags Details
X Server Log File_Old (47.43 KB, text/plain)
2008-05-26 14:54 EDT, Prasad Dhanakodi
no flags Details
X Org log (50.80 KB, text/plain)
2008-05-28 13:34 EDT, Prasad Dhanakodi
no flags Details
Log file after changing to openchrome in xorg file (48.87 KB, text/plain)
2008-06-01 08:30 EDT, Prasad Dhanakodi
no flags Details
Xorg log after adding openchrome and video ram size in Xorg.conf (1.09 KB, text/plain)
2008-06-01 09:00 EDT, Prasad Dhanakodi
no flags Details
Fedora 9 Xorg.conf (598 bytes, text/plain)
2008-06-01 12:08 EDT, Prasad Dhanakodi
no flags Details
Fedora 9 Xorg.log file (39.30 KB, text/plain)
2008-06-01 12:09 EDT, Prasad Dhanakodi
no flags Details
Xorg.conf after setting the VideoRam option (650 bytes, text/plain)
2008-06-03 13:22 EDT, Prasad Dhanakodi
no flags Details
Xorg log file after the system restart (56.37 KB, text/plain)
2008-06-03 13:22 EDT, Prasad Dhanakodi
no flags Details
My Desktop now displays properly (411.04 KB, image/png)
2008-06-03 13:23 EDT, Prasad Dhanakodi
no flags Details

  None (edit)
Description Prasad Dhanakodi 2008-05-24 04:02:02 EDT
Description of problem:
In my system when I insert the Fedora 9 x86 DVD and boot, it does not display
the correct resolution for my monitor (Samsung SyncMaster 793s). Instead it
displays only in the resolution 640 x 400 and the display goes towards the left
of the monitor. So, I tried to install in text mode and after installation again
the system displays the 640 x 400 resolution. I tried both upgrade from Fedora 8
and also a fresh install, but it ended up in the same result. So, I again did a
fresh install of Fedora 8.

I tried using KDE Live CD also, even there it take only the 640 x 400 resolution.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Insert the x686 DVD and boot from it
2. Install Fedora 9
3. Reboot the system
  
Actual results: 
As the result the newly installed Fedora 9 starts with really a strange
resolution, which was not supported by the monitor. And also the display extends
to the left corner of my monitor and so not all the display area is visible on
the screen. That is, around 3/4th or the display are is only visible on the
screen. I have attached screen shot of KDE Live CD for your understanding.

Expected results:
The DVD has to take the most fitted monitors resolution (1152 x 864) as it does
in the previous version Fedora 8.

Additional info:
My Hardware Profile in Smolt is under (taken in Fedora 8):
http://www.smolts.org/show?uuid=pub_c48d7fca-1fee-45b6-9722-75f433157572

Images Attached:
Camera shot of Fedora 9 booting from x86 DVD
Comment 1 Prasad Dhanakodi 2008-05-24 04:02:02 EDT
Created attachment 306561 [details]
Fedora 9 Booting from DVD
Comment 2 Prasad Dhanakodi 2008-05-24 04:03:48 EDT
Created attachment 306562 [details]
Camera shot of KDE Live Desktop in my system
Comment 3 Matěj Cepl 2008-05-26 10:16:58 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Prasad Dhanakodi 2008-05-26 14:53:21 EDT
Created attachment 306699 [details]
X Server Config File (/etc/X11/xorg.conf)
Comment 5 Prasad Dhanakodi 2008-05-26 14:54:03 EDT
Created attachment 306700 [details]
X Server Log File
Comment 6 Prasad Dhanakodi 2008-05-26 14:54:30 EDT
Created attachment 306701 [details]
X Server Log File_Old
Comment 7 Prasad Dhanakodi 2008-05-26 14:59:37 EDT
I had attached my X Server Config file and log file for your reference. These
files are taken from my Fedora 8 system.

I am a beginner in Linux and so I do not know how to run without X server config
file. So, I need help in this regard on how to run Linux without xorg.config.
Please give me the steps to reproduce, so that I will do it myself and update
the bug with the results.
Comment 8 Matěj Cepl 2008-05-27 06:58:16 EDT
Just (as root) rename /etc/X11/xorg.conf to whatever else and restart computer.
Comment 9 Prasad Dhanakodi 2008-05-28 13:33:57 EDT
I renamed /etc/X/xorg.conf to /etc/X/xorg.conf and restarted the computer. I had
attached the Xorg.log file for your reference.
Comment 10 Prasad Dhanakodi 2008-05-28 13:34:32 EDT
Created attachment 306957 [details]
X Org log
Comment 12 Xavier Bachelot 2008-05-30 06:42:20 EDT
What would be really interesting is an xorg log with xorg-x11-drv-openchrome
driver rather than the old xorg-x11-drv-via.

F8 defaults to use via although openchrome is also available ('yum install
xorg-x11-drv-openchrome' then change the device driver to openchrome instead of
via in /etc/X11/xorg.conf) while F9 defaults to openchrome.

As you're now running F8, could you please install openchrome driver as
explained above, then restart X and post the xorg log ? Getting back to via
driver if openchrome doesn't work is just a matter of switching back to via
instead of openchrome in the xorg.conf.
Comment 13 Xavier Bachelot 2008-05-31 08:11:39 EDT
It might possibly a case of video ram size misdetection. If the openchrome
driver doesn't work out of the box, try to force the video ram size with :
    Option "VideoRAM" "32768"
in the Device section of /etc/X11/xorg.conf.
Comment 14 Prasad Dhanakodi 2008-06-01 08:30:13 EDT
Created attachment 307308 [details]
Log file after changing to openchrome in xorg file
Comment 15 Prasad Dhanakodi 2008-06-01 09:00:03 EDT
Reproduced the steps as given in Comment #13 by adding the video ram size in the
device section of Xorg file. But, the X server again failed to start. I had
attached the xorg log file below.
Comment 16 Prasad Dhanakodi 2008-06-01 09:00:48 EDT
Created attachment 307310 [details]
Xorg log after adding openchrome and video ram size in Xorg.conf
Comment 17 Xavier Bachelot 2008-06-01 09:07:34 EDT
from Log in comment #14, the video ram size is misdetected, as I though.
However, from log in comment #16, I believe you didn't use the VideoRam option
properly. Could you please attach /etc/X11/xorg.conf so I can fix it ?
Comment 18 Prasad Dhanakodi 2008-06-01 12:07:39 EDT
I again did a fresh installation Fedora 9 in my system. The X org does not run
properly as I reported earlier. I had retained Fedora 9 installation. So, I had
attached my Fedora 9's Xorg.conf and Xorg.log here.
Comment 19 Prasad Dhanakodi 2008-06-01 12:08:25 EDT
Created attachment 307313 [details]
Fedora 9 Xorg.conf
Comment 20 Prasad Dhanakodi 2008-06-01 12:09:16 EDT
Created attachment 307314 [details]
Fedora 9 Xorg.log file
Comment 21 Prasad Dhanakodi 2008-06-01 12:10:44 EDT
Per your comment #17, please fix the VideoRam option in the latest Xorg file so
that I canb try running that configuration in my new Fedora 9 system.
Comment 22 Xavier Bachelot 2008-06-01 13:42:19 EDT
The Device section of your xorg conf should look like that :

Section "Device"
	Identifier  "Videocard0"
	Driver      "openchrome"
        Option      "VideoRAM" "32768"
EndSection
Comment 23 Prasad Dhanakodi 2008-06-03 13:20:58 EDT
After adding the VideoRam option in the xorg.conf as suggested above, the system
now recognizes the correct monitor resolution and my system display is working
properly as before. Thank for your extended help in resolving this issue.

I had attached my xorg.conf, xorg log file and a screen shot of Fedora 9 desktop
in my system for your reference.

And also please let me know the procedure to close this bug. Thank you once
again for resolving my issue.
Comment 24 Prasad Dhanakodi 2008-06-03 13:22:26 EDT
Created attachment 308266 [details]
Xorg.conf after setting the VideoRam option
Comment 25 Prasad Dhanakodi 2008-06-03 13:22:56 EDT
Created attachment 308267 [details]
Xorg log file after the system restart
Comment 26 Prasad Dhanakodi 2008-06-03 13:23:42 EDT
Created attachment 308268 [details]
My Desktop now displays properly
Comment 27 Xavier Bachelot 2008-06-03 14:35:44 EDT
The issue is not properly fixed, this is just a temporary workaround. I'm going
to keep this bug open until upstream comes with a real fix for this. I may get
back to you and ask for some tests later.

Regards,
Xavier
Comment 28 Prasad Dhanakodi 2008-06-03 15:13:05 EDT
Hi Xavier,

As you said we shall go ahead and keep this bug open until we get a fix for this
issue. I am always ready to help by giving the possible information from my side.

Thanks,
Prasad
Comment 29 Xavier Bachelot 2008-10-10 09:36:35 EDT
Upstream bug : http://www.openchrome.org/trac/ticket/177
Comment 30 Jóhann B. Guðmundsson 2009-01-06 08:18:28 EST
Could you update to the latest version, retest and report back to see if this still remains an issue for you.

You can get the latest update from here.

http://koji.fedoraproject.org/koji/packageinfo?packageID=5229

Thank you.
Comment 31 Xavier Bachelot 2009-03-22 07:37:50 EDT
Prasad, does latest openchrome driver from either F10 updates (0.2.903-5.fc10)
or F10-updates-testing (0.2.903-6.fc10) help ? Can you please provided an
updated xorg log ?
Comment 32 Matěj Cepl 2009-05-18 07:49:14 EDT
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 33 Bug Zapper 2009-06-09 21:08:06 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 34 Bug Zapper 2009-07-14 13:25:35 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 35 John Poelstra 2009-11-16 12:10:07 EST
There is no information as to why this bug has been reopened.  Fedora 9 is no longer supported.  Closing.

Note You need to log in before you can comment on or make changes to this bug.