Bug 448194 - Xfce: You can't shutdown by clicking Quit (desktop menu) then Shutdown
Xfce: You can't shutdown by clicking Quit (desktop menu) then Shutdown
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 04:41 EDT by Mark Summerfield
Modified: 2009-02-25 12:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:32:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Summerfield 2008-05-24 04:41:28 EDT
If you click the desktop menu then click Quit you get a dialog.
One of the options is shutdown, but if you click it you just get returned to the
login screen which is annoying.

I solved this by uncommenting the last line in /etc/sudooers:
%users  localhost=/sbin/shutdown -h now

after which everything works fine.
Comment 1 Mark Summerfield 2008-05-24 04:42:45 EDT
Of course the filename is /etc/sudoers
(Also the file says it must only be edited by visudos by that doesn't seem to be
available.)
Comment 2 Mark Summerfield 2008-05-24 04:59:46 EDT
My "fix" only worked once. Now it isn't possible to shutdown again.
I'll go back to KDE 3.5.
Comment 3 Christoph Wickert 2008-05-24 05:45:13 EDT
Mark, in Xfce 4.4 the shutdown/reboot is triggered via dbus/hal and should work
out of the box. In Xfce 4.2 it was based on sudo, so one needs to edit
/etc/sudoers once and add

  ALL=NOPASSWD:/usr/sbin/xfsm-shutdown-helper

Unfortunately there is no way for us to do this automatically.

If you get an error message about /etc/sudoers then I guess you are still on
Xfce 4.2. Please give us the output of "rpm -q xfce4-panel".
Comment 4 Christoph Wickert 2008-05-24 05:52:59 EDT
Correction: This needs to bee

  ALL=NOPASSWD:/usr/libexec/xfsm-shutdown-helper
Comment 5 Mark Summerfield 2008-05-24 08:33:23 EDT
I just installed the standard xfce that comes with Fedora 8 using Pirut, i.e.,
xfce4-panel.i386 4.4.2-1.fc8, etc., so maybe it is okay in Fedora 9.
Anyway, I've switched back to KDE now.
Thanks.
Comment 6 Christoph Wickert 2008-05-24 09:04:12 EDT
(In reply to comment #5)
> I just installed the standard xfce that comes with Fedora 8 using Pirut, i.e.,
> xfce4-panel.i386 4.4.2-1.fc8, etc., so maybe it is okay in Fedora 9.

This is strange, it has been working in Fedora 7 and 8 too.

> Anyway, I've switched back to KDE now.
> Thanks.

The above fix will also work with Xfce 4.4, because it falls back to sudo if
hald is not available. But I'd like to ask you to help me troubleshooting this
issue because you might just have encountered a hal or dbus problem. 
Please log in to xfce and open a terminal
  ps -A | grep dbus
  ps -A | grep hald
Do you have dbus and hald running?

Then try the following:
  killall xfce4-panel && xfce4-panel 

When you now hit the shutdown button, do you see something like
  "HAL not available or does not permit to shutdown/reboot the computer, trying
sudo fallback instead" on the terminal just before you logout? Or do you have
anything like this in .xsession-errors?

What login manager are you running? gdm?

TIA!
Comment 7 Kevin Fenzi 2008-05-24 13:37:06 EDT
This looks like a duplicate or at least related to: 
https://bugzilla.redhat.com/show_bug.cgi?id=444789

I haven't heard anything back from the reporter there however. ;( 
Comment 8 Mark Summerfield 2008-05-26 03:17:33 EDT
I already used Pirut to remove Xfce entirely---I had only been experimenting
with it.
And I'm loathe to reinstall it because when I went back to KDE I discovered that
my Desktop Menu had been completely messed up. The only way I could find to
restore it was to install kmenu-gnome.
Comment 9 das 2008-05-28 01:54:50 EDT
The same problem in Xfce in F9. 

rpm -q xfce4-panel => xfce4-panel-4.4.2-4.fc9.i386

I added the line to /etc/sudoers:
ALL=NOPASSWD:/usr/libexec/xfsm-shutdown-helper

Still Quit -> 'restart' or Quit -> 'shutdown' is not working. All three
restart/shutdown/logout results the same, that is, logout.

On the console back in init 3 I get some error message with something like
xfce-mcs-manager and hald. 
Comment 10 das 2008-05-28 02:17:48 EDT
Let me copy the error message. I am typing this by doing the restart from my
laptop, so minor errors may be there.
<<
** (xfdesktop.3491): CRITICAL **: settings_register_callback" assertion 'cb &&
user_data && mcs_client' failed

** (xfdesktop.3491): CRITICAL **: settings_register_callback" assertion 'cb &&
user_data && mcs_client' failed
could not attach to desktop process

** (xfce-session:3336): WARNING **: xfsm-shutdown-helper.c:176: Failed to
contact HAL: org.freedessktop.hal.power-management.reboot-multiple-sessions
auth_admin <-- (action, result)

** (xfce-session:3336): WARNING **: Failed to perform shutdown action!

waiting for X server to shut down xfce-mcs-manager: Fatal IO error 11 (Resource
temporarily unavailable) on X server :0.0. 
xfce-panel: Fatal IO error 4 (Interrupted system call) on X server :0.0.
.
>>
Comment 11 das 2008-05-28 02:19:01 EDT
This was the error after I added that line to the /etc/sudoers file.
Comment 12 Kevin Fenzi 2008-06-06 14:53:11 EDT
As mentioned before you shouldn't need to do anything with sudo, as it's all
handled via dbus/hal now just fine. 

Das: Can you provide the debugging that Christoph was looking for from comment #6? 


Comment 13 Bug Zapper 2008-11-26 05:46:05 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bug Zapper 2009-01-09 01:32:45 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.