Bug 448202 - Firefox3.0 starts in "Offline mode" even when there is a valid network available
Firefox3.0 starts in "Offline mode" even when there is a valid network available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 07:25 EDT by Imtiaz Rahi
Modified: 2008-05-24 11:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-24 11:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 191889 None None None Never

  None (edit)
Description Imtiaz Rahi 2008-05-24 07:25:49 EDT
Description of problem:
When I start firefox from the panel it always start in offline mode. I am
connected via ethernet using DHCP to a network that is always on. I am not using
NetworkManager but "network" is enabled When I want to browse I need to unclick
"work offline".
But again when Firefox is started the "Work Offline" check box is enabled
automatically. Has to be disabled every time.

Version-Release number of selected component (if applicable):
Firefox 3.0b5

How reproducible:
Disable NetworkManager. Enable network "chkconfig network on". Use firefox.

Steps to Reproduce:
1. Disable NetworkManager and stop it.
2. Enable network "chkconfig network on" and start it.
3. Start Firefox
  
Actual results:
Firefox3.0b5 starts in Offline mode. Has to check off "Work Offline" every time.

Expected results:
Firefox starts and should be able to browse without checking off "Work Offline"
all the time.

Additional info:
Comment 1 Christopher Aillon 2008-05-24 11:35:58 EDT
There is no good way to test for a valid network without NetworkManager, without
actually pegging the network, which could be slow because of DNS queries, etc. 
To avoid doing this and delaying startup, Firefox uses NM to query for network
available.

NetworkManager is a core component of desktop.  It used to be disabled by
default in older Fedora versions because we felt it was not ready for everyone
to use.  Now we do feel it is ready for everyone to use and have updated our
client software accordingly; thus disabling it is not recommended on client
machines as some software will have broken/strange functionality.

Note You need to log in before you can comment on or make changes to this bug.