Bug 448220 - Pulseaudio: AC3 Support does not work anymore
Pulseaudio: AC3 Support does not work anymore
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 12:09 EDT by Christian Nolte
Modified: 2008-06-13 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 19:41:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log of the latest updates on my machine (10.99 KB, application/octet-stream)
2008-05-24 12:09 EDT, Christian Nolte
no flags Details

  None (edit)
Description Christian Nolte 2008-05-24 12:09:07 EDT
Since some updates (I have not figured out what is the exact problem here) AC3
passthrough using pulseaudio does not work anymore. The yum.log is attached. AC3
Passthrough did work on the 14th of may.

Smolt-Profile:
http://www.smolts.org/client/show/pub_b75f1860-8199-486a-b3b8-5047dd56f614
Comment 1 Christian Nolte 2008-05-24 12:09:07 EDT
Created attachment 306584 [details]
yum log of the latest updates on my machine
Comment 2 Christian Nolte 2008-05-24 12:10:20 EDT
Disabling pulseaudio via /etc/alsa/alsa.conf "fixes" this problem for me:

@hooks [
        {
                func load
                files [
#                       "/etc/alsa/pulse-default.conf"
                        "/etc/asound.conf"
                        "~/.asoundrc"
                ]
                errors false
        }
]
Comment 3 Lennart Poettering 2008-06-13 19:41:06 EDT
PulseAudio doesn't do AC3 pass-through. If you want to use it, then you have to
use the spdif ALSA plugin and bypass PA. If PA is blocking access to the audio
device you might want to wrap your call in "pasuspender".

Note You need to log in before you can comment on or make changes to this bug.