Bug 448223 - lm_sensors does not support it8718 chips
lm_sensors does not support it8718 chips
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lm_sensors (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Nikola Pajkovsky
:
Depends On: 559950
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 14:08 EDT by Phil Perry
Modified: 2014-02-02 17:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 03:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3286 None None None Never

  None (edit)
Description Phil Perry 2008-05-24 14:08:03 EDT
Description of problem:

lm_sensors does not return data for it87xx sensors once additional chipset 
support for it8718 is enabled in patch provided for bug
https://bugzilla.redhat.com/show_bug.cgi?id=446061


Version-Release number of selected component (if applicable):
lm_sensors-2.10.0-3.1.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install patch to it87 module provided in bug 446061
2. Configure lm_sensors
3. Run 'sensors'
  
Actual results:
$ sensors
it8718-isa-0290
Adapter: ISA adapter

Expected results:
$ sensors
it8718-isa-0290
Adapter: ISA adapter
in0:       +1.31 V  (min =  +0.00 V, max =  +4.08 V)
in1:       +2.18 V  (min =  +0.00 V, max =  +4.08 V)
in2:       +3.30 V  (min =  +0.00 V, max =  +4.08 V)
in3:       +2.99 V  (min =  +0.00 V, max =  +4.08 V)
in4:       +0.69 V  (min =  +0.00 V, max =  +4.08 V)
in5:       +0.06 V  (min =  +0.00 V, max =  +4.08 V)
in6:       +0.11 V  (min =  +0.00 V, max =  +4.08 V)
in7:       +3.04 V  (min =  +0.00 V, max =  +4.08 V)
in8:       +3.30 V
fan1:     1516 RPM  (min =    0 RPM)
fan2:        0 RPM  (min =    0 RPM)
fan3:        0 RPM  (min =    0 RPM)
temp1:       +40°C  (low  =  +127°C, high =  +127°C)   sensor = thermistor
temp2:       +38°C  (low  =  +127°C, high =   +70°C)   sensor = diode
temp3:        -2°C  (low  =  +127°C, high =  +127°C)   sensor = thermistor
vid:      +0.000 V

Additional info:

Please refer to bug 446061: https://bugzilla.redhat.com/show_bug.cgi?id=446061

This issue is fixed in later releases of lm_sensors. For example,
lm_sensors-2.10.3-2 from Fedora Core 7 works as expected.

I am happy to test any fix offered.
Comment 1 Niels de Vos 2008-12-05 07:18:04 EST
Same problem here with a it8718F-chip on CentOS-5.2. The feature request on the CentOS-bugtracker contains updated patches and spec for lm_sensors-2.10.7.
Comment 2 Phil Knirsch 2008-12-19 10:23:21 EST
Proposing for RHEL-5.4.

Thanks & regards, Phil
Comment 3 Phil Perry 2008-12-19 11:13:47 EST
Unless I'm mistaken, the version of lm_sensors proposed for RHEL-5.3 should fix this bug (requires lm_sensors >= 2.10.2). It is BugID 446061 that needs some movement. I have tested the supplied patch for 6 months and provided feedback yet there's still no sign of moving this forward towards release (it's still not fixed in the RHEL-5.3 beta kernels).

Thanks
Comment 12 errata-xmlrpc 2010-03-30 03:57:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0186.html

Note You need to log in before you can comment on or make changes to this bug.