Bug 448231 - ScummVM won't load flight of the amazon queen
ScummVM won't load flight of the amazon queen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: flight-of-the-amazon-queen (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 15:30 EDT by Vegard Nossum
Modified: 2008-05-24 16:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-24 16:12:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vegard Nossum 2008-05-24 15:30:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
$ scummvm 
Using configuration file: /home/vegard/.scummvmrc
Looking for queen
Trying to start game 'Flight of the Amazon Queen'
WARNING: No path was provided. Assuming the data files are in the current direct
ory!
Could not open resource file 'queen.1[c]'!


Version-Release number of selected component (if applicable):
flight-of-the-amazon-queen-1.0-2

How reproducible:
Always


Steps to Reproduce:
1. Start ScummVM
2. Choose "Flight of the Amazon Queen" in the game list
3. Click "Start Game"

Actual Results:
$ scummvm 
Using configuration file: /home/vegard/.scummvmrc
Looking for queen
Trying to start game 'Flight of the Amazon Queen'
WARNING: No path was provided. Assuming the data files are in the current direct
ory!
Could not open resource file 'queen.1[c]'!


Expected Results:


Additional info:
Comment 1 Hans de Goede 2008-05-24 16:04:47 EDT
Hmm,

Indeed it seems there is a bug in scummvm where it does remember that fotaq is
available once it has been started once, but it forgets the location.

Workarounds:
1) Use the provided applications menu entry
2) Use "scummvm -f -p /usr/share/flight-of-the-amazon-queen queen"
3) In the game chooser select fotaq, then choise edit game, then select
   the paths tab and then edit "Game Path" and point it to:
   /usr/share/flight-of-the-amazon-queen

I'll report this bug upstream.
Comment 2 Hans de Goede 2008-05-24 16:12:17 EDT
Reported upstream, since I'm rather unfamiliar with the coe, and a workable
workaround exists I'll let them handle this.

Note You need to log in before you can comment on or make changes to this bug.