Bug 448242 - iwl4965 does not find APs with high frequencies
iwl4965 does not find APs with high frequencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 17:41 EDT by Christoph Höger
Modified: 2008-05-29 14:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 14:56:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Höger 2008-05-24 17:41:44 EDT
Description of problem:
Wireless Chip does not detect an AP when channel is higher than 11, 9 works fine.

Version-Release number of selected component (if applicable):
version:        1.2.26kds

Steps to Reproduce:
1. make AP use channel 12
2. iwlist scanning
  
Actual results:
AP not listed

Expected results:
AP in list


Additional info: 
This seems to occur on an iwl3945 with ubuntu 8.04 too.
Comment 1 John W. Linville 2008-05-27 11:09:51 EDT
The cfg80211 component is defaulting to settings for the US regulatory domain. 
Channels 12 and 13 are not available in the US.

Future plans include a much more flexible mechanism for handling regulatory
issues, but currently the only other regulatory domain known to the kernel is
one for Japan.  But, it does include channels 12 and 13.  You can make those
channels available by adding a line like this to /etc/modprobe.conf:

   options cfg80211 ieee80211_regdom="JP"

Please ensure that you are complying with local laws regarding wireless
communications!  Does this make those channels available for you?
Comment 2 Christoph Höger 2008-05-29 14:56:03 EDT
Thannk you for your answer. This makes this not a bug.

Note You need to log in before you can comment on or make changes to this bug.