Bug 448246 - X Frequently Spikes CPU Time Over 80 Percent
X Frequently Spikes CPU Time Over 80 Percent
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 18:07 EDT by Randy Yates
Modified: 2008-05-26 10:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 10:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
top.log with the event occurring at line 16269 (2.45 MB, text/plain)
2008-05-24 18:07 EDT, Randy Yates
no flags Details
a screenshot of gkrellm with the spikes visible in the cpu usage window (20.25 KB, image/png)
2008-05-24 18:14 EDT, Randy Yates
no flags Details
Xorg.0.log (30.05 KB, text/plain)
2008-05-24 18:16 EDT, Randy Yates
no flags Details

  None (edit)
Description Randy Yates 2008-05-24 18:07:31 EDT
Description of problem:

X frequently (but at irregular intervals) grabs 80 percent or more of the cpu
time for short periods (~1 second). The interval varies from a few seconds to 45
seconds (very approximately). The spike in cpu usage is so severe that
keystrokes (e.g., being entered into an editor) are lost. 

Version-Release number of selected component (if applicable):

Using gnome WITHOUT compiz enabled (i.e., so that metacity is the window
manager). I've confirmed the problem with nothing but xterm running in a gnome
login session. I'm using the kmod-nvidia driver. 

How reproducible:

There are times when it doesn't happen at all. But usually it is producible.

Steps to Reproduce:

1.Log in
2.run top -b -d 0.2 >top.log for at least 45 seconds
3. Search top.log for "X" occupying CPU time of at least 80 percent.
  
Additional info:

Linux localhost.localdomain 2.6.24.7-92.fc8 #1 SMP Wed May 7 16:26:02 EDT 2008
x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Randy Yates 2008-05-24 18:07:31 EDT
Created attachment 306588 [details]
top.log with the event occurring at line 16269
Comment 2 Randy Yates 2008-05-24 18:14:32 EDT
Created attachment 306589 [details]
a screenshot of gkrellm with the spikes visible in the cpu usage window
Comment 3 Randy Yates 2008-05-24 18:16:05 EDT
Created attachment 306590 [details]
Xorg.0.log
Comment 4 Matěj Cepl 2008-05-26 10:48:44 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.