Bug 448260 - Kernel oops in r8169 driver during startup.
Kernel oops in r8169 driver during startup.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 01:17 EDT by Gilboa Davara
Modified: 2008-06-09 23:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.25.4-10.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-09 23:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of kernel oops (21.07 KB, text/plain)
2008-06-06 15:51 EDT, Soren Juelsgaard
no flags Details

  None (edit)
Description Gilboa Davara 2008-05-25 01:17:25 EDT
Since the latest kernel update I get OOPs when trying to initialize the r8169
PCI GbE NIC.
The OOPs is fully reproducible.
Kernel log attached.
Previous kernels did not exhibit this problem.

Kernel version:
2.6.24.7-92.fc8-x86_64.

Serial console log:
Bringing up interface eth0:  [  OK  ]
Bringing up interface eth1:  ------------[ cut here ]------------
kernel BUG at lib/list_debug.c:33!
invalid opcode: 0000 [1] SMP
CPU 1
Modules linked in: ipv6 ipt_LOG ipt_MASQUERADE xt_tcpudp xt_state iptable_nat
nf_nat nf_conntrack_ipv4 nf_conntrack iptable_filter ip_tables x_tables
dm_multipath raid1 kvm_amd kvm snd_usb_audio snd_ens1371 gameport snd_hda_intel
snd_ac97_codec snd_seq_dummy ac97_bus snd_seq_oss snd_seq_midi_event snd_seq
snd_pcm_oss snd_mixer_oss snd_pcm snd_usb_lib firewire_ohci snd_rawmidi k8temp
floppy snd_seq_device firewire_core snd_timer snd_hwdep hwmon r8169 snd
snd_page_alloc crc_itu_t hci_usb i2c_nforce2 forcedeth bluetooth soundcore
i2c_core button sg sr_mod cdrom usb_storage pata_amd sata_nv dm_snapshot dm_zero
dm_mirror dm_mod ahci libata sd_mod scsi_mod raid456 async_xor async_memcpy
async_tx xor ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd
Pid: 10, comm: events/1 Not tainted 2.6.24.7-92.fc8 #1
RIP: 0010:[<ffffffff8112d2fa>]  [<ffffffff8112d2fa>] __list_add+0x47/0x5b
RSP: 0018:ffff81013fa9dd60  EFLAGS: 00010082
RAX: 0000000000000079 RBX: ffff81013c929460 RCX: 0000000000009a85
RDX: 00000000ffffffff RSI: ffffffff813498fa RDI: ffffffff81394020
RBP: ffff81013fa64000 R08: 0000000000000000 R09: ffffffff81292d00
R10: 0000000000000038 R11: ffffffff811ee8bc R12: ffff81013fa64000
R13: 00000000fffc2186 R14: 0000000000000000 R15: 0000000000000080
FS:  00002aaaaaaf6f50(0000) GS:ffff81013fc01780(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 0000000000918e40 CR3: 0000000139578000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process events/1 (pid: 10, threadinfo ffff81013fa9c000, task ffff81013fa988b0)
Stack:  00000000fffc2186 ffffffff81041522 0000000000000046 0000000000000086
 ffff81013c929440 ffff81013c929460 00000000ffffffff 0000000000000004
 ffffffff881aac64 ffffffff81047f0b ffff81013c928700 ffff81013f072000
Call Trace:
 [<ffffffff81041522>] __mod_timer+0xb6/0xd2
 [<ffffffff881aac64>] :r8169:rtl8169_interrupt+0x0/0x230
 [<ffffffff81047f0b>] queue_delayed_work_on+0xaf/0xbe
 [<ffffffff881aae0d>] :r8169:rtl8169_interrupt+0x1a9/0x230
 [<ffffffff81070e6a>] request_irq+0xb1/0xe4
 [<ffffffff881ab471>] :r8169:rtl8169_open+0x11b/0x1d9
 [<ffffffff881aceaf>] :r8169:rtl8169_reinit_task+0x0/0x77
 [<ffffffff881acee1>] :r8169:rtl8169_reinit_task+0x32/0x77
 [<ffffffff881aceaf>] :r8169:rtl8169_reinit_task+0x0/0x77
 [<ffffffff8104769d>] run_workqueue+0x7f/0x10b
 [<ffffffff81047fa5>] worker_thread+0x0/0xe4
 [<ffffffff8104807f>] worker_thread+0xda/0xe4
 [<ffffffff8104af95>] autoremove_wake_function+0x0/0x2e
 [<ffffffff8104ae66>] kthread+0x47/0x75
 [<ffffffff8100cca8>] child_rip+0xa/0x12
 [<ffffffff8104ae1f>] kthread+0x0/0x75
 [<ffffffff8100cc9e>] child_rip+0x0/0x12


Code: 0f 0b eb fe 48 89 7e 08 48 89 37 48 89 57 08 48 89 3a 5a c3
RIP  [<ffffffff8112d2fa>] __list_add+0x47/0x5b
 RSP <ffff81013fa9dd60>
---[ end trace dc56ddd84122fbe7 ]---
eth0: no IPv6 routers present
Comment 1 kenichi sudoh 2008-05-28 11:28:00 EDT
Same problem occured from 2.6.24 to 2.6.25.3 kernels.
I tried kernel-2.6.25.4. Status is good!

Back ported "Fix oops r8169 get_mac_version" to kernel-2.6.24.7-92 on Fedora8.
Rebuilded kernel rpm file, new name is kernel-2.6.24.7-93 .
Install new kernel. Status is good!

Fixed kernel posted to http://www.pochinet.org/library.htm
But this page is Japanese !
Please search "kernel-2.6.24.7-93".

32 bit -> kernel-2.6.24.7-93.fc8.i686.rpm 
64 bit -> kernel-2.6.24.7-93.fc8.x86_64.rpm 


Best regard.
Have a fun ! Have a nice day !
Comment 2 Soren Juelsgaard 2008-06-06 15:51:13 EDT
Created attachment 308562 [details]
dmesg of kernel oops
Comment 3 Soren Juelsgaard 2008-06-06 15:52:58 EDT
I have the same problem with Intel's Atom motherboard for 2.6.24.7-92.fc8.i686.
I will try Kenichi's fix above.

Regards,
/Soren
Comment 4 kenichi sudoh 2008-06-08 07:23:43 EDT
Information
Fedora8 updated to kernel 2.6.25.4 base.(kernel-2.6.25.4-10)
Maybe fix the problem.
Comment 5 Soren Juelsgaard 2008-06-08 20:00:27 EDT
I tried the 2.6.25.4 kernel from the Fedora 8 updates, and it solved the problem.

Thank you very much.

Regards,
/Soren

Note You need to log in before you can comment on or make changes to this bug.