Bug 448266 - move symlink into totem-gstreamer subrpm
move symlink into totem-gstreamer subrpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 03:35 EDT by Florian La Roche
Modified: 2008-05-25 12:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-25 12:07:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2008-05-25 03:35:59 EDT
Description of problem:

The shared lib is moved to totem-gstreamer, but the symlink is still in
the main binary rpm:

main binary rpm:
lrwxrwxrwx    1 root    root               28 May 21 20:31
/usr/lib/libbaconvideowidget.so.0 -> libbaconvideowidget.so.0.0.0

$ rpm -qplv totem-gstreamer-2.23.3-2.fc10.i386.rpm
-rwxr-xr-x    1 root    root           134508 May 21 20:31
/usr/lib/libbaconvideowidget-gstreamer.so.0.0.0


regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stewart Adam 2008-05-25 12:07:36 EDT
This is the desired behaviour because alternatives is used to configure the
backends. If you have both totem-gstreamer and totem-xine installed,
alternatives switches the symlink (libbaconvideowidget.so.0) to point to one of
the two backend libraries, and that library file (ie
libbaconvideowidget-gstreamer.so.0.0.0) is owned by the backend subpackage.

Note You need to log in before you can comment on or make changes to this bug.