Bug 448278 - Google Earth, etracer, bzflag assertion failures
Google Earth, etracer, bzflag assertion failures
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 07:19 EDT by Richard Körber
Modified: 2009-07-14 13:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Google Earth crashlog (4.12 KB, text/plain)
2008-05-25 07:21 EDT, Richard Körber
no flags Details
Xorg log file (23.33 KB, text/plain)
2008-05-25 07:23 EDT, Richard Körber
no flags Details
xorg.conf file (593 bytes, text/plain)
2008-05-25 07:24 EDT, Richard Körber
no flags Details
.xsession-errors for etracer crash (1.25 KB, text/plain)
2008-06-13 09:23 EDT, Tim Wegener
no flags Details

  None (edit)
Description Richard Körber 2008-05-25 07:19:45 EDT
Description of problem:
Google Earth always crashes after a few seconds. It starts normally, opens the
main window and shows a spinning earth, but after a few seconds the application
closes itself and returns an error message.

On Fedora 8, Google Earth was running allright on this machine. There were some
minor graphical glitches, but the application did not crash.

Version-Release number of selected component (if applicable):
Google Earth 4.3.7204
kernel-2.6.25.3-18.fc9.x86_64
xorg-x11-drv-i810-2.2.1-24.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install and run Google Earth
  
Actual results:
It always crashes after a few seconds.

Expected results:
It does not crash. ;)

Additional info:
When exporting LIBGL_ALWAYS_INDIRECT=1 (which is required to start Compiz Fusion
and not getting a white screen), Google Earth crashes after a few more seconds,
and then even closes the entire X session.

It's a Lenovo R61 with Intel Corporation Mobile GM965/GL960 Integrated Graphics
Controller and a clean Fedora 9 x86_64 and a clean Google Earth installation.
I'm not sure if this is the right component to file this bug against.

Google Earth crash reports and xorg.log will follow...
Comment 1 Richard Körber 2008-05-25 07:21:27 EDT
Failed to initialize TTM buffer manager.  Falling back to classic.
googleearth-bin: ../common/dri_bufmgr_fake.c:982: dri_fake_emit_reloc:
Zusicherung »target_fake->is_static || target_fake->size_accounted« nicht erfüllt.
Google Earth has caught signal 6.

Stacktrace from glibc:
  ./googleearth-bin [0x804f403]
  ./googleearth-bin [0x804f916]
  [0x110400]
  [0x6]
  /lib/libc.so.6(abort+0x188) [0xefd028]
  /lib/libc.so.6(__assert_fail+0xee) [0xef457e]
  /usr/lib/dri/i965_dri.so [0x1c08066]
  /usr/lib/dri/i965_dri.so(dri_emit_reloc+0x1f) [0x1c069d1]
  /usr/lib/dri/i965_dri.so(intel_batchbuffer_emit_reloc+0x34) [0x1c0832c]
  /usr/lib/dri/i965_dri.so(brw_emit_vertices+0xed) [0x1c22e76]
  /usr/lib/dri/i965_dri.so(brw_draw_prims+0x335) [0x1c228a1]
  /usr/lib/dri/libdricore.so [0x1d1d603]
  /usr/lib/dri/libdricore.so [0x1d1d7f3]
 
/opt/google-earth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext11genericDrawEiiiii+0x29b)
[0x12a594b]
 
/opt/google-earth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext12internalDrawENS0_11IG_GFX_DRAWEiiii+0xc8)
[0x12bf8a8]
 
/opt/google-earth/libIGGfx.so(_ZN3Gap3Gfx18igOglVisualContext11drawIndexedENS0_11IG_GFX_DRAWEiiii+0x30)
[0x12bf8e0]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData9flushGeomEPN3Gap3Gfx15igVisualContextEPS1_RPtRiS9_S9_+0xc5)
[0x152e525]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData12drawGeomListERSt6vectorIPS1_SaIS3_EERKNS_5Vec3dEPN3Gap3Gfx15igVisualContextEbPKNS_11BoundingBoxIdS7_EEb+0x40f)
[0x152e9af]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData13drawGeomListsEPN3Gap3Gfx15igVisualContextEi+0xe4)
[0x152ed94]
 
/opt/google-earth/libevll.so(_ZN5earth4evll12DrawableData16drawDrawableListEPN3Gap3Gfx15igVisualContextE+0x1c0)
[0x152efa0]
  /opt/google-earth/libevll.so(_ZN5earth4evll8Database16DrawDrawablesAllEv+0x1f)
[0x14e939f]
  /opt/google-earth/libevll.so(_ZN5earth4evll13VisualContext6renderEb+0xabd)
[0x1466d9d]
  /opt/google-earth/libevll.so(_ZN5earth4evll13VisualContext4drawEbb+0x1c4)
[0x14696a4]
  /opt/google-earth/libevll.so(_ZN5earth4evll17RenderContextImpl4drawEv+0x166)
[0x1605ec6]
  ./librender.so(_ZN12RenderWidget10paintEventEP11QPaintEvent+0x2a) [0x4269caa]
  ./librender.so(_ZN5earth6render11RenderTimer4fireEv+0x1a) [0x42771ca]
  ./libbase.so(_ZN5earth5Timer8dispatchEv+0x2d) [0x81246cd]
 
./libgoogleearth_lib.so(_ZN5earth6client11Application18CommandCustomEvent8dispatchEv+0x23)
[0xe453f3]
 
./libgoogleearth_lib.so(_ZN5earth6client11Application11customEventEP6QEvent+0x3a) [0xe36dea]
  ./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0xed) [0x2d89a1]
 
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0x1d3)
[0x8b944b]
  ./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0xb4) [0x8bffc0]
  ./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x62)
[0x2caeda]
 
./libQtCore.so.4(_ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData+0x247)
[0x2cc9db]
  ./libQtCore.so.4(_ZN16QCoreApplication16sendPostedEventsEP7QObjecti+0x23)
[0x2ccc4f]
  ./libQtCore.so.4 [0x2eaa9a]
  /lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8) [0x84aa098]
  /lib/libglib-2.0.so.0 [0x84ad743]
  /lib/libglib-2.0.so.0(g_main_context_iteration+0x71) [0x84ad901]
 
./libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x53)
[0x2ea61b]
  ./libQtGui.so.4 [0x927c92]
 
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x2d)
[0x2ca861]
  ./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xc7)
[0x2caa07]
  ./libQtCore.so.4(_ZN16QCoreApplication4execEv+0x98) [0x2cccf0]
  ./libQtGui.so.4(_ZN12QApplication4execEv+0x25) [0x8b8f15]
  ./libgoogleearth_lib.so(_ZN5earth6client11Application3runEv+0x380) [0xe434e0]
  ./googleearth-bin(main+0x2ba) [0x8050bea]
  /lib/libc.so.6(__libc_start_main+0xe6) [0xee75d6]
  ./googleearth-bin [0x804f231]




We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data are now being written
 to this text file:

    /home/shred/.googleearth/crashlogs/crashlog-C695B575.txt

This bug report will be sent to Google automatically next time you run
 Google Earth. Its data, which contains no personal information, will help
 us correct problems without bothering you further. If you would rather
 this info not be transmitted, please delete the above file before running
 the program again. If you want bug reports to NEVER be sent, remove the
 above 'crashlogs' directory's read/write permissions.
Comment 2 Richard Körber 2008-05-25 07:21:57 EDT
Created attachment 306606 [details]
Google Earth crashlog
Comment 3 Richard Körber 2008-05-25 07:23:39 EDT
Created attachment 306607 [details]
Xorg log file
Comment 4 Richard Körber 2008-05-25 07:24:13 EDT
Created attachment 306608 [details]
xorg.conf file
Comment 5 Thomas J. Baker 2008-05-29 11:42:14 EDT
I don't get a crash but I a similar warning messages and glacial performance. 

continuity> googleearth 
Failed to initialize TTM buffer manager.  Falling back to classic.
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try running with LIBGL_THROTTLE_REFRESH and LIBL_SYNC_REFRESH unset.

I've tried the latest koji versions of mesa and the i810 driver on an Intel
Corporation Mobile 945GM/GMS controller and running x86_64.
Comment 6 Kevin Kofler 2008-05-31 13:00:01 EDT
Extreme Tux Racer triggers the same assertion failure:
etracer: ../common/dri_bufmgr_fake.c:982: dri_fake_emit_reloc: Assertion
`target_fake->is_static || target_fake->size_accounted' failed.
Comment 7 Kevin Kofler 2008-05-31 13:03:30 EDT
FYI:
extremetuxracer-0.4-1.fc9.x86_64
xorg-x11-drv-i810-2.2.1-24.fc9.x86_64
Comment 8 Kevin Kofler 2008-05-31 13:06:22 EDT
To reproduce the assertion failure with etracer, go to Practice and click on Race
to start the race (any track).

This is with Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller
(rev 03) on an asMobile S37E laptop.
Comment 9 Tim Wegener 2008-06-13 09:22:28 EDT
(In reply to comment #8)
I experience the exact same problem with etracer with Intel GM965/GL960 on an HP
6710b laptop.

When choosing 'race' it bombs out with that error message in .xsession-errors
mentioned above, and leaves X in whatever resolution etracer was using (640x480
in this case) and the mouse is not responsive. I have to ctrl-alt-backspace and
log back in again. 

Comment 10 Tim Wegener 2008-06-13 09:23:37 EDT
Created attachment 309209 [details]
.xsession-errors for etracer crash
Comment 11 Kevin Kofler 2008-07-03 12:02:56 EDT
etracer still causes this assertion failure with the updated mesa packages from 
the 7.1-0.35.fc9 update and with xorg-x11-drv-i810-2.3.2-2.fc9 from 
updates-testing.
Comment 12 Nils Philippsen 2008-07-08 11:23:02 EDT
Same here with bzflag, with Intel GM965/GL960 on Dell Latitude D830.
Comment 13 Peter Gordon 2008-07-23 20:00:34 EDT
Same here with bzflag, Intel G965 ("X3000") on a DG865WH desktop motherboard. :(
Comment 14 Peter Gordon 2008-10-26 21:18:44 EDT
I upgraded my F9 system to the normal updates plus mesa-7.1-1.fc9 from Koji, and I'm no longer experiencing this issue. (Though, I've only tried with BZFlag.) Do others see a similar fix?
Comment 15 Tim Wegener 2008-10-26 21:40:42 EDT
Extreme Tux Racer (etracer) and BZFlag are now working for me in Fedora 10/rawhide with current mesa/xorg. (Intel GM965/GL960 on an HP 6710b laptop)
Comment 16 Kevin Kofler 2008-10-26 22:28:52 EDT
So can we get that mesa update pushed out?
Comment 17 Kevin Kofler 2008-10-27 12:36:50 EDT
I fetched all the packages from the mesa-7.1-1.fc9 build and upgraded to them, but etracer still triggers the assertion failure (and yes, I rebooted since the upgrade).
Comment 18 Bug Zapper 2009-06-09 21:09:42 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Kevin Kofler 2009-06-09 21:16:48 EDT
This is fixed in F10. No idea whether it's fixed in F9 updates, I'm no longer running F9 on the Intel machine.
Comment 20 Bug Zapper 2009-07-14 13:42:10 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.