This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448280 - Deprecation should be mentioned in Release Notes as well as way how to replace it with xrandr
Deprecation should be mentioned in Release Notes as well as way how to replac...
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 07:24 EDT by Daniel Veillard
Modified: 2008-09-04 08:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 08:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file for the Xserver (38.89 KB, text/plain)
2008-05-25 07:24 EDT, Daniel Veillard
no flags Details
The server configuration file (3.02 KB, text/plain)
2008-05-25 07:29 EDT, Daniel Veillard
no flags Details

  None (edit)
Description Daniel Veillard 2008-05-25 07:24:56 EDT
Description of problem:

Using a xinerama display in F8, upgrade to F9, X just crashes after a few
seconds (I can see the greyed pattern on both screen and move the nouse 
around both screens).

Commenting out 
#       Option      "Xinerama" "on"

allows to start gdm, log in and work, but without Xinerama.

I tried initally with NVidia AGP nv driver + Matrox Millenium PCI,
then reproduced this with just 2 Matrox  Millenium PCI cards. I don't
have any AGP dual head card to try.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.x86_64

How reproducible:

systematic if I have a Section "ServerLayout" with Option "Xinerama" "on"

Steps to Reproduce:
1. Option      "Xinerama" "on"
2. startx watch the screen go grey on both screens
3. goes back to text mode without clear error
  
Actual results:

X does not start with
Option      "Xinerama" "on"
X starts if said option is disabled

Expected results:

X does not start with Xinerama

Additional info:

Appending the Xorg.log ... no error found
Comment 1 Daniel Veillard 2008-05-25 07:24:56 EDT
Created attachment 306609 [details]
log file for the Xserver
Comment 2 Daniel Veillard 2008-05-25 07:29:23 EDT
Created attachment 306610 [details]
The server configuration file

I tried many variations like:
  - with the Nv driver for the Videocard0
  - the DRI and Extensions sections at the end are just
    things I tried to get this to work
Only if I disable Xinerama startx actually bring a server which stays on
Comment 3 Matěj Cepl 2008-05-26 10:23:32 EDT
Hi, Daniel,

in the new wonderful RANDR world we don't like Xinerama, anymore, try to setup
it with xrandr(1), please.
Comment 4 Daniel Veillard 2008-05-26 10:46:51 EDT
I only found now Ulrich post about it.
http://udrepper.livejournal.com/20187.html
I'm still impressed that deprecating such a feature didn't even
got something in the Fedora 9 release notes...
And the fact the X server don't complain about it but just shutdown
after a few seconds is really crazy. It *does* work ... for 2 seconds.
I won't be able to test until I go back to Grenoble.
I did however use the XRandr administration tool, clicked on
the detection button but it didn't list anything.
SShing to the box I see
[root@paphio ~]# xrandr 
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
VGA1 disconnected
DVI0 connected 1680x1050+0+0 473mm x 296mm
   1680x1050      59.9*+
   1280x1024      75.0     59.9  
   1152x864       74.8  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
VGA0 disconnected
[root@paphio ~]# 

  Advice welcome on how to use 2 different cards, i hope it will
work with my old PCI Matrox cards.

Daniel

Daniel
Comment 5 Matěj Cepl 2008-05-26 13:08:12 EDT
You are right, this should be in Release Notes.
Comment 6 Karsten Wade 2008-05-27 13:53:25 EDT
When the wiki goes back to writable later today, please add a note to the
appropriate relnotes beat:

http://fedoraproject.org/wiki/Docs/Beats/

In the commit comment please note that this is for an F9 update.  We don't have
an update of the site or package planned, but are more likely to do one when
content such as this is included.
Comment 7 Matěj Cepl 2008-05-28 07:00:31 EDT
This is meant for F9 Release notes, not Rawhide.
Comment 8 Karsten Wade 2008-06-04 03:21:37 EDT
(In reply to comment #7)
> This is meant for F9 Release notes, not Rawhide.

Right, just add it to the wiki here:

https://fedoraproject.org/wiki/Docs/Beats/Xorg

... and note in the change comment that it is intended for a Fedora 9 relnotes
update.
Comment 9 Matěj Cepl 2008-06-04 17:43:56 EDT
Done
Comment 10 Matěj Cepl 2008-06-04 17:49:46 EDT
(In reply to comment #4)
> SShing to the box I see
> [root@paphio ~]# xrandr 
> Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
> ...
> Advice welcome on how to use 2 different cards,

Sorry, I totally forgot to answer this question: you missed "-q" parameter of
xrandr. See Ulrich's blogpost -- it should be

xrandr -q

which lists all available configuration options.

> i hope it will work with my old PCI Matrox cards.

Unfortunately, I am doubtful about this (and ajax, when I asked him, was
non-optimistic as well).
Comment 11 Jason Taylor 2008-08-28 10:46:24 EDT
This appears to be fixed, the current release note beats reflect the change. Any reason we can't close this bug?
Comment 12 Karsten Wade 2008-08-28 11:06:00 EDT
Did this make an update for the F9 release notes?  I don't see it here:

http://docs.fedoraproject.org/release-notes/f9/en_US/sn-Xorg.html

Just updating the website should be good enough, since the on-disk notes reference the on-line notes as the latest.

Jason -- let me know if you want to do the fix (in XML), rebuild, and publish of the update, or any part of that.  I'll be glad to pick up and finish whatever is needed at this point.

Note You need to log in before you can comment on or make changes to this bug.