Bug 448283 - suspend/resume-to/from-ram only works once, the next time the computer doesn't resume any more (Samsung X20).
suspend/resume-to/from-ram only works once, the next time the computer doesn'...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 08:55 EDT by Jens Lautenbacher
Modified: 2008-06-15 17:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-15 17:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from hal-device (110.13 KB, application/octet-stream)
2008-05-25 08:55 EDT, Jens Lautenbacher
no flags Details
output of lspci (1.96 KB, application/octet-stream)
2008-05-25 08:57 EDT, Jens Lautenbacher
no flags Details

  None (edit)
Description Jens Lautenbacher 2008-05-25 08:55:16 EDT
Description of problem:

I can suspend and resume the machine successfully one time, the next time I 
suspend the machine, the resume will not work any more. There is some disk
activity seen, but the screen stays dark. it's also not possible to do anything
without seeing (under the assumption that only the graphic chip is not
initialized) like STRG-ALT-1 and then pressing the reboot combo STRG-ALT-DEL, or
even just pressing the power knob of the laptop that normally triggers a
shutdown. Only option is a hard shutdown/reset.

Version-Release number of selected component (if applicable):

kernel-2.6.25.3-18.fc9.i686

Laptop is a Samsung X20 with intel graphics chip. See attached output from
hal-device and lspci.

How reproducible: always :-(
suspend for the second time after power up, try to resume -> bang.
  
Actual results: resume hangs the second time

Expected results: suspend/resume works

Please tell me if I can help with any additional info!
Comment 1 Jens Lautenbacher 2008-05-25 08:55:16 EDT
Created attachment 306613 [details]
Output from hal-device
Comment 2 Jens Lautenbacher 2008-05-25 08:57:13 EDT
Created attachment 306614 [details]
output of lspci
Comment 3 Jens Lautenbacher 2008-06-15 17:39:54 EDT
Well, it now works for me with - at least - newer kernels. I don't know exactly
what finally made it work, if it was a kernel upgrade or something else (maybe
X/video related???)

For now I'll be closing the bug to reduce noise.

Note You need to log in before you can comment on or make changes to this bug.