Bug 448286 - Popt 1.14 released
Popt 1.14 released
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: popt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 293531
  Show dependency treegraph
 
Reported: 2008-05-25 09:39 EDT by Robert Scheck
Modified: 2014-01-24 02:40 EST (History)
3 users (show)

See Also:
Fixed In Version: popt-1.16-2.fc19
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-24 13:13:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-05-25 09:39:44 EDT
Description of problem:
Popt 1.14 was released on April 6th, 2008 while Fedora Rawhide hangs around
at the older 1.13 version.

Version-Release number of selected component (if applicable):
popt-1.13-3

Expected results:
Upgrade to 1.14... ;-)
Comment 1 Robert Scheck 2008-05-25 09:44:47 EDT
I already prepared locally a build of popt 1.14, but it currently seems to have
a bug which shows up when the locale is not C and the string contains a non-
ascii character, see http://rpm5.org/community/popt-devel/0115.html - and so I
am waiting for a fix before upgrading the package. The new package then should 
solve bug #293531.
Comment 2 Panu Matilainen 2011-05-25 04:41:35 EDT
Ping, any plans on updating popt to a more recent version one of these days (years ;)

popt-1.13 is getting a bit long in the tooth...
Comment 3 Robert Scheck 2011-05-25 04:59:32 EDT
Panu, is there somebody who could solve the still existing issue mentioned
in comment #1, because there's still no fix for it. I'm not really happy to introduce a new version where I already know a regression...
Comment 4 Panu Matilainen 2011-05-25 05:18:57 EDT
Ugh, character encoding business makes my head hurt :) Probably easier to just backport the fix for bug 293531 instead (which is what I'm mostly interested here). I'll try to have a look at these somewhen...
Comment 5 Yannick Brosseau 2013-05-28 14:15:44 EDT
I'm trying to reproduce the problem on my system, but I'm not able to. Is the bug still present or am I missing something?
Comment 6 Account closed by the user 2013-11-03 07:06:06 EST
FYI: 1.16 was released (long)time ago, see bug 999377
Comment 7 Robert Scheck 2013-11-24 08:38:00 EST
If I am not mistaken, comment #1 is still valid. However I can do an update...
Comment 8 Fedora Update System 2013-11-24 13:22:40 EST
popt-1.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/popt-1.16-1.fc20
Comment 9 Fedora Update System 2013-12-13 22:49:18 EST
popt-1.16-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-01-08 14:14:41 EST
popt-1.16-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/popt-1.16-2.fc19
Comment 11 Fedora Update System 2014-01-24 02:40:16 EST
popt-1.16-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.