Bug 44829 - Xnest authorization change?
Xnest authorization change?
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-06-18 02:06 EDT by Havoc Pennington
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-16 02:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2001-06-18 02:06:14 EDT
Just upgraded to 7.1 + errata, suddenly Xnest doesn't seem to work, it
rejects all client connections. 

It will print something like:
 AUDIT: Mon Jun 18 01:59:04 2001: 25726 Xnest: client 1 rejected from local

And clients can't connect.

Maybe this is just me being dumb instead of a bug, but it's at least a docs
bug, I have no clue how to enable connections to the Xnest ;-)
I've never had trouble in the past.
Comment 1 Havoc Pennington 2001-06-18 11:09:57 EDT
Owen points out that I can disable access controls with "Xnest -ac" or 
somehow get xauthority to work with "-auth". 

Neither is in the Xnest man page, and Xnest is useless unless you pass one of
these options as far as I can tell. So I think it should exit with the error
message "must pass -auth or -ac" if you don't pass one.

Clearly this is material for an upstream change not a RH patch...
Comment 2 Mike A. Harris 2001-06-18 20:59:27 EDT
Which 4.1.0 release is it causing the problem?
Comment 3 Havoc Pennington 2001-06-18 22:16:43 EDT
I seem to have 4.0.3-5.

Possibly the rationale for this behavior is that you could use Xnest to test how
authentication works...
Comment 4 Mike A. Harris 2001-06-19 01:18:40 EDT
I've tried various combinations of Xnest tonight having never used it before,
and it is c001.  ;o)  I tried 3 different 4.0.3 releases including -5, -16,
and -21.  They all work, so I think it is a local authentication issue.
Here is what I did:

1) Running stock 7.1 KDE, I open up a konsole
2) Xnest :2
3) xmorph -d :2

it works.  I tried other apps too, and it works.  I seem to recall 
someone else having a similar problem but not with Xnest.  Good chance
this is similar.  I think it is just config issue though I believe. What
are you using to run it?  GNOME/KDE?  What term program?

Comment 5 Havoc Pennington 2001-06-19 01:31:02 EDT
Interesting. So I assume the issue is gone in newer Xnest or something.

I'm using gnome-terminal, just tried xterm and it's the same. I can't imagine
how that would make any difference though.
Comment 6 Mike A. Harris 2001-06-19 01:39:01 EDT
I can't either, but I just wanted to be able to try and dupe what 
you're using.  Are you using only stock 7.1+updates?  Or + GNOME 1.4 also?
Comment 7 Havoc Pennington 2001-06-19 11:48:47 EDT
I had a mostly 7.0 system, ran the 7.1 installer, then ran up2date to get all
Comment 8 Mike A. Harris 2001-07-16 02:57:50 EDT
I don't have any problem using Xnest in stock 7.1 with 4.0.3-5, or with the
above mentioned releases, nor with 7.1 + XFree86-4.1.0-0.8.6 nor with
our latest internal CD snapshot of the next release.  I don't know what
the problem you're having but I have no trouble running it at all.
I do not have any special customized X configuration, just stock, no
.xinitrc, .anything that might mess with this.  Check your configs for
anything that might mess with the authentication mechanisms.
I am assuming you are running Xnest locally on the same box as the Xserver
resides.  Is this correct?
Comment 9 Havoc Pennington 2001-07-16 08:57:14 EDT
I can't even reproduce this now; I still have the same X version. Random
transient bogon.

Note You need to log in before you can comment on or make changes to this bug.