Bug 448294 - Doxygen on RHEL 4 behaves multilib unfriendly, please update doxygen
Doxygen on RHEL 4 behaves multilib unfriendly, please update doxygen
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: doxygen (Show other bugs)
4.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 10:51 EDT by Robert Scheck
Modified: 2008-08-22 06:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-22 06:29:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-05-25 10:51:30 EDT
Description of problem:
It looks like the doxygen shipped with RHEL 4 behaves very multilib/multiarch 
unfriendly - please update to a newer version.

Comparing libopm-devel-0.1-6.20050731cvs.el4.i386.rpm and libopm-devel-0.1-
6.20050731cvs.el4.x86_64.rpm by using http://katzj.fedorapeople.org/multilib-
cmp.py, there are many multilib conflicts, while comparing libopm-0.1-
7.20050731cvs.fc7.i386.rpm and libopm-0.1-7.20050731cvs.fc7.x86_64.rpm, there
is no multilib conflict. Note, that the same spec file was used for .el4 and
.fc7+ - as the only files which are different come from doxygen generated 
stuff, I'm blaming doxygen herefore...

Version-Release number of selected component (if applicable):
doxygen-1.3.9.1-1

How reproducible:
Everytime. Grab libopm-devel-0.1-7.20050731cvs.fc7.src.rpm and rebuild in 
Fedora 7 mockbuild and grab libopm-devel-0.1-6.20050731cvs.el4.src.rpm and 
rebuild in EPEL 4 mockbuild. Then run the multilib-cmp.py script and you'll
see the conflicts on .el5. And feel free to compare the specs of libopm, but 
they're identical :)

Actual results:
Doxygen on RHEL 4 behaves multilib unfriendly.

Expected results:
Doxygen on RHEL 4 behaves same multilib friendly as on Fedora 7+.

Additional info:
I think, I'm hereby reporting the same, as I already reported with bug #429425 
for Fedora 7 and 8. So please solve for RHEL 4 as well. Thank you.
Comment 1 Robert Scheck 2008-05-25 11:14:46 EDT
Sorry, this does not apply to RHEL 4 - closing. But for RHEL 5 this is valid. 
Please close the bug report e.g. with NOTABUG because I'm not permissioned for.
Comment 2 Phil Knirsch 2008-08-22 06:29:58 EDT
Closed as per comment #1.

Thanks,

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.