Bug 448302 - Inkscape crash on startup
Inkscape crash on startup
Status: CLOSED DUPLICATE of bug 447349
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
9
powerpc Linux
low Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 13:14 EDT by Albrecht Dreß
Modified: 2008-05-27 00:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 00:45:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albrecht Dreß 2008-05-25 13:14:18 EDT
Description of problem:
Inkscape reproducibly crashes on start-up.

Version-Release number of selected component (if applicable):
inkscape-0.46-2.fc9.ppc

How reproducible:
Always

Steps to Reproduce:
1. launch Inkscape
  
Actual results:
crash

Additional info:
running in gdb:
<snip>
(gdb) run
Starting program: /usr/bin/inkscape 
[Thread debugging using libthread_db enabled]
[New Thread 0x4810a0f0 (LWP 18460)]

Program received signal SIGSEGV, Segmentation fault.
0x0ecc5e18 in signal_emit_unlocked_R (node=<value optimized out>, detail=<value
optimized out>, 
    instance=<value optimized out>, emission_return=<value optimized out>,
instance_and_params=<value optimized out>)
    at gsignal.c:2285
2285      continue_emission = accumulator->func (ihint, return_accu,
handler_return, accumulator->data);
Current language:  auto; currently c
Missing separate debuginfos, use: debuginfo-install avahi.ppc bug-buddy.ppc
e2fsprogs.ppc elfutils.ppc enchant.ppc expat.ppc gtk2-engines.ppc keyutils.ppc
krb5.ppc libXau.ppc libXcomposite.ppc libXcursor.ppc libXdmcp.ppc libXext.ppc
libXfixes.ppc libXi.ppc libXinerama.ppc libXrandr.ppc libcap.ppc libjpeg.ppc
libselinux.ppc libxcb.ppc pixman.ppc
(gdb) bt full
#0  0x0ecc5e18 in signal_emit_unlocked_R (node=<value optimized out>,
detail=<value optimized out>, 
    instance=<value optimized out>, emission_return=<value optimized out>,
instance_and_params=<value optimized out>)
    at gsignal.c:2285
        accumulator = <value optimized out>
        emission = Could not find the frame base for "signal_emit_unlocked_R".
(gdb) 
</snip>
Comment 1 Ian Weller 2008-05-27 00:45:31 EDT

*** This bug has been marked as a duplicate of 447349 ***

Note You need to log in before you can comment on or make changes to this bug.