Bug 448306 - Devhelp crash on startup
Devhelp crash on startup
Status: CLOSED DUPLICATE of bug 448307
Product: Fedora
Classification: Fedora
Component: devhelp (Show other bugs)
9
powerpc Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 14:19 EDT by Albrecht Dreß
Modified: 2008-07-28 20:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-28 20:07:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albrecht Dreß 2008-05-25 14:19:31 EDT
Description of problem:
Reproducible crash on startup

Version-Release number of selected component (if applicable):
devhelp-0.19-4.fc9.ppc

How reproducible:
always

Additional info:
Bug Buddy collected data:
<snip>
Distribution: Fedora release 9 (Sulphur)
Gnome Release: 2.22.1 2008-05-07 (Red Hat, Inc)
BugBuddy Version: 2.22.0

System: Linux 2.6.25.3-18.fc9.ppc #1 Tue May 13 04:30:41 EDT 2008 ppc
X Vendor: The X.Org Foundation
X Vendor Release: 10499901
Selinux: No
Accessibility: Disabled
GTK+ Theme: Mist
Icon Theme: Tango

Memory status: size: 220270592 vsize: 220270592 resident: 38486016 share:
18616320 rss: 38486016 rss_rlim: 4294967295
CPU usage: start_time: 1211739396 rtime: 379 utime: 350 stime: 29 cutime:0
cstime: 0 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/devhelp'

[Thread debugging using libthread_db enabled]
[New Thread 0x48107d10 (LWP 18836)]
[New Thread 0x50818460 (LWP 18841)]
[New Thread 0x4fe18460 (LWP 18840)]
[New Thread 0x4f418460 (LWP 18839)]
[New Thread 0x4ea18460 (LWP 18838)]
[New Thread 0x48ea4460 (LWP 18837)]
0x0fcc1aa0 in waitpid () from /lib/libpthread.so.0
Current language:  auto; currently asm
#0  0x0fcc1aa0 in waitpid () from /lib/libpthread.so.0
#1  0x0ee8ee7c in IA__g_spawn_sync (working_directory=<value optimized out>, 
    argv=<value optimized out>, envp=<value optimized out>, 
    flags=<value optimized out>, child_setup=<value optimized out>, 
    user_data=<value optimized out>, standard_output=<value optimized out>, 
    standard_error=<value optimized out>, exit_status=<value optimized out>, 
    error=<value optimized out>) at gspawn.c:374
#2  0x0ee8f0bc in IA__g_spawn_command_line_sync (
    command_line=<value optimized out>, 
    standard_output=<value optimized out>, 
    standard_error=<value optimized out>, exit_status=<value optimized out>, 
    error=<value optimized out>) at gspawn.c:682
#3  0x0e7ae37c in ?? () from /usr/lib/gtk-2.0/modules/libgnomebreakpad.so
#4  0x0e7ae464 in ?? () from /usr/lib/gtk-2.0/modules/libgnomebreakpad.so
#5  0x02b1eafc in nsProfileLock::FatalSignalHandler (
    signo=<value optimized out>) at nsProfileLock.cpp:216
#6  <signal handler called>
#7  0x0ecc5e18 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, 
    instance_and_params=<value optimized out>) at gsignal.c:2285
#8  0x0ecc7abc in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#9  0x0ecc8028 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>)
    at gsignal.c:2243
#10 0x0270b914 in IA__gtk_widget_realize (widget=) at gtkwidget.c:3259
#11 0x0fbf38d4 in window_open_new_tab (window=<value optimized out>, 
    location=<value optimized out>) at dh-window.c:1214
#12 0x0fbf4f18 in dh_window_new (base=<value optimized out>)
    at dh-window.c:578
#13 0x0fbeb70c in dh_base_new_window (base=<value optimized out>)
    at dh-base.c:376
#14 0x100022dc in main (argc=1, argv=0xbfb22704) at dh-main.c:192

Thread 6 (Thread 0x48ea4460 (LWP 18837)):
#0  0x0feeed7c in __poll (fds=<value optimized out>, 
    nfds=<value optimized out>, timeout=<value optimized out>)
    at ../sysdeps/unix/sysv/linux/poll.c:87
	r4 = <value optimized out>
	r7 = <value optimized out>
	r12 = <value optimized out>
	r5 = <value optimized out>
	r8 = <value optimized out>
	r10 = <value optimized out>
	r0 = <value optimized out>
	r3 = <value optimized out>
	r6 = <value optimized out>
	r9 = <value optimized out>
	r11 = <value optimized out>
	sc_ret = <value optimized out>
	oldtype = <value optimized out>
#1  0x00caa950 in _pr_poll_with_poll (pds=<value optimized out>, 
    npds=<value optimized out>, timeout=<value optimized out>)
    at ../../../mozilla/nsprpub/pr/src/pthreads/ptio.c:3895
	stack_syspoll = 
Thread 5 (Thread 0x4ea18460 (LWP 18838)):
#0  0x0fcbc4f8 in __pthread_cond_timedwait (cond=<value optimized out>, 
    mutex=<value optimized out>, abstime=<value optimized out>)
    at pthread_cond_timedwait.c:160
	r4 = <value optimized out>
	r7 = <value optimized out>
	r12 = <value optimized out>
	r5 = <value optimized out>
	r8 = <value optimized out>
	r10 = <value optimized out>
	r0 = <value optimized out>
	r3 = <value optimized out>
	r6 = <value optimized out>
	r9 = <value optimized out>
	r11 = <value optimized out>
	arg1 = <value optimized out>
	__ret = <value optimized out>
	rt = Current language:  auto; currently c

Thread 4 (Thread 0x4f418460 (LWP 18839)):
#0  0x0fcbbf44 in __pthread_cond_wait (cond=<value optimized out>, 
    mutex=<value optimized out>) at pthread_cond_wait.c:153
	r4 = <value optimized out>
	r7 = <value optimized out>
	r12 = <value optimized out>
	r5 = <value optimized out>
	r8 = <value optimized out>
	r10 = <value optimized out>
	r0 = <value optimized out>
	r3 = <value optimized out>
	r6 = <value optimized out>
	r9 = <value optimized out>
	r11 = <value optimized out>
	arg1 = <value optimized out>
	futex_val = <value optimized out>
	buffer = 
Thread 3 (Thread 0x4fe18460 (LWP 18840)):
#0  0x0fcbbf44 in __pthread_cond_wait (cond=<value optimized out>, 
    mutex=<value optimized out>) at pthread_cond_wait.c:153
	r4 = <value optimized out>
	r7 = <value optimized out>
	r12 = <value optimized out>
	r5 = <value optimized out>
	r8 = <value optimized out>
	r10 = <value optimized out>
	r0 = <value optimized out>
	r3 = <value optimized out>
	r6 = <value optimized out>
	r9 = <value optimized out>
	r11 = <value optimized out>
	arg1 = <value optimized out>
	futex_val = <value optimized out>
	buffer = 
Thread 2 (Thread 0x50818460 (LWP 18841)):
#0  0x0fcbc4f8 in __pthread_cond_timedwait (cond=<value optimized out>, 
    mutex=<value optimized out>, abstime=<value optimized out>)
    at pthread_cond_timedwait.c:160
	r4 = <value optimized out>
	r7 = <value optimized out>
	r12 = <value optimized out>
	r5 = <value optimized out>
	r8 = <value optimized out>
	r10 = <value optimized out>
	r0 = <value optimized out>
	r3 = <value optimized out>
	r6 = <value optimized out>
	r9 = <value optimized out>
	r11 = <value optimized out>
	arg1 = <value optimized out>
	__ret = <value optimized out>
	rt = 
Thread 1 (Thread 0x48107d10 (LWP 18836)):
#0  0x0fcc1aa0 in waitpid () from /lib/libpthread.so.0
No locals.
#1  0x0ee8ee7c in IA__g_spawn_sync (working_directory=<value optimized out>, 
    argv=<value optimized out>, envp=<value optimized out>, 
    flags=<value optimized out>, child_setup=<value optimized out>, 
    user_data=<value optimized out>, standard_output=<value optimized out>, 
    standard_error=<value optimized out>, exit_status=<value optimized out>, 
    error=<value optimized out>) at gspawn.c:374
	outpipe = <value optimized out>
	errpipe = <value optimized out>
	pid = <value optimized out>
	fds = Current language:  auto; currently asm

The program is running.  Quit anyway (and detach it)? (y or n) [answered Y;
input not from terminal]
</snip>
Comment 1 W. Michael Petullo 2008-06-03 20:08:56 EDT
Is this related to bug #446014?
Comment 2 Matěj Cepl 2008-07-28 20:07:00 EDT

*** This bug has been marked as a duplicate of 448307 ***

Note You need to log in before you can comment on or make changes to this bug.