Bug 448308 - Crash when exporting set of pictures to a directory
Crash when exporting set of pictures to a directory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Nigel Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 15:07 EDT by Jeremy Fitzhardinge
Modified: 2009-04-02 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.4.3.1-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2008-05-25 15:07:39 EDT
Description of problem:
Crash when exporting set of pictures to a directory

Version-Release number of selected component (if applicable):
f-spot-0.4.2-5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1.Select a moderate number of pictures
2.Choose "Export to folder"
3.
  
Actual results:
Save images to folder

Expected results:
Crash

Additional info:
Crash output:

f-spot: xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) -
(dpy->request)) >= 0)' failed.
Stacktrace:

  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0x00004>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0xffffffff>
  at Gtk.Application.Run () <0x00007>
  at Gnome.Program.Run () <0x00007>
  at FSpot.Driver.Main (string[]) <0x00cf1>
  at (wrapper runtime-invoke) FSpot.Driver.runtime_invoke_int_string[]
(object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

	f-spot [0x81796be]
	[0x11040c]
	[0x110416]
	/lib/libc.so.6(gsignal+0x50) [0xb49660]
	/lib/libc.so.6(abort+0x188) [0xb4b028]
	/lib/libc.so.6(__assert_fail+0xee) [0xb4257e]
	/usr/lib/libX11.so.6 [0x118af14]
	/usr/lib/libX11.so.6(_XSend+0x63) [0x118c2f3]
	/usr/lib/libX11.so.6(_XFlush+0x32) [0x118c4b2]
	/usr/lib/libX11.so.6(XFlush+0x31) [0x1163b41]
	/usr/lib/libgdk-x11-2.0.so.0(gdk_display_flush+0xa0) [0x5aac384]
	/usr/lib/libgdk-x11-2.0.so.0 [0x5aa312c]
	/usr/lib/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xf8) [0x5aa3244]
	/usr/lib/libgtk-x11-2.0.so.0 [0x443b5b0]
	/usr/lib/libgdk-x11-2.0.so.0 [0x5a81649]
	/lib/libglib-2.0.so.0 [0x239181]
	/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8) [0x23b098]
	/lib/libglib-2.0.so.0 [0x23e743]
	/lib/libglib-2.0.so.0(g_main_loop_run+0x1d2) [0x23ec62]
	/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xe0) [0x44f390d]
	[0x1e507ee]
	[0x1e507b8]
	[0x1e507a0]
	[0x1364f2]
	[0x1351c4]
	f-spot(mono_runtime_exec_main+0xf7) [0x809a787]
	f-spot(mono_runtime_run_main+0x16d) [0x809ad6d]
	f-spot(mono_main+0x623) [0x8058b53]
	f-spot [0x8058042]
	/lib/libc.so.6(__libc_start_main+0xe6) [0xb355d6]
	f-spot [0x8057f81]

Debug info from gdb:

(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x113cc0 (LWP 25889)]
[New Thread 0x67a1b90 (LWP 26553)]
[New Thread 0x3d0eb90 (LWP 26524)]
[New Thread 0x34e6b90 (LWP 25898)]
[New Thread 0x2438b90 (LWP 25897)]
[New Thread 0x8cbeb90 (LWP 25892)]
[New Thread 0x5e49b90 (LWP 25891)]
[New Thread 0x1b5b90 (LWP 25890)]
0x00110416 in __kernel_vsyscall ()
  8 Thread 0x1b5b90 (LWP 25890)  0x00110416 in __kernel_vsyscall ()
  7 Thread 0x5e49b90 (LWP 25891)  0x00110416 in __kernel_vsyscall ()
  6 Thread 0x8cbeb90 (LWP 25892)  0x00110416 in __kernel_vsyscall ()
  5 Thread 0x2438b90 (LWP 25897)  0x00110416 in __kernel_vsyscall ()
  4 Thread 0x34e6b90 (LWP 25898)  0x00110416 in __kernel_vsyscall ()
  3 Thread 0x3d0eb90 (LWP 26524)  0x00110416 in __kernel_vsyscall ()
  2 Thread 0x67a1b90 (LWP 26553)  0x00110416 in __kernel_vsyscall ()
* 1 Thread 0x113cc0 (LWP 25889)  0x00110416 in __kernel_vsyscall ()

Thread 8 (Thread 0x1b5b90 (LWP 25890)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc9426 in nanosleep () from /lib/libpthread.so.0
#2  0x0810ed08 in ?? ()
#3  0x00cc232f in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#4  0x00bfd27e in clone () from /lib/libc.so.6

Thread 7 (Thread 0x5e49b90 (LWP 25891)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc5b95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x08112757 in ?? ()
#3  0x08114d2c in ?? ()
#4  0x08114d6c in ?? ()
#5  0x0812783f in ?? ()
#6  0x080b38fa in ?? ()
#7  0x080d3c54 in ?? ()
#8  0x08125cde in ?? ()
#9  0x0813e107 in ?? ()
#10 0x00cc232f in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#11 0x00bfd27e in clone () from /lib/libc.so.6

Thread 6 (Thread 0x8cbeb90 (LWP 25892)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc5ec2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x08112708 in ?? ()
#3  0x08114d2c in ?? ()
#4  0x08114d6c in ?? ()
#5  0x0812783f in ?? ()
#6  0x080d0cf3 in ?? ()
#7  0x01666752 in ?? ()
#8  0x04fb34b0 in ?? ()
#9  0x00000411 in ?? ()
#10 0xffffffff in ?? ()
#11 0x00000000 in ?? ()

Thread 5 (Thread 0x2438b90 (LWP 25897)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc5ec2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x08112708 in ?? ()
#3  0x08114d2c in ?? ()
#4  0x08114d6c in ?? ()
#5  0x0812783f in ?? ()
#6  0x080cf501 in ?? ()
#7  0x01efef42 in ?? ()
#8  0xb6416738 in ?? ()
#9  0xffffffff in ?? ()
#10 0x09650360 in ?? ()
#11 0x09650360 in ?? ()
#12 0x00140b12 in ?? ()
#13 0xb6416720 in ?? ()
#14 0x00000000 in ?? ()

Thread 4 (Thread 0x34e6b90 (LWP 25898)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc5ec2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x08112708 in ?? ()
#3  0x08114d2c in ?? ()
#4  0x08114d6c in ?? ()
#5  0x0812783f in ?? ()
#6  0x080cf501 in ?? ()
#7  0x01efef42 in ?? ()
#8  0xb6cfc818 in ?? ()
#9  0xffffffff in ?? ()
#10 0x09651308 in ?? ()
#11 0x09651308 in ?? ()
#12 0x01eff06d in ?? ()
#13 0x00012000 in ?? ()
#14 0xb6cfc7e0 in ?? ()
#15 0xb6cfc818 in ?? ()
#16 0x00000001 in ?? ()
#17 0x034e61fc in ?? ()
#18 0x01efef1c in ?? ()
#19 0x034e6214 in ?? ()
#20 0x01efee26 in ?? ()
#21 0xb6cfc818 in ?? ()
#22 0xffffffff in ?? ()
#23 0x0007c9a0 in ?? ()
#24 0x09651a20 in ?? ()
#25 0x034e6254 in ?? ()
#26 0x01efed46 in ?? ()
#27 0xb6cfc818 in ?? ()
#28 0x00651a20 in ?? ()
#29 0x00000000 in ?? ()

Thread 3 (Thread 0x3d0eb90 (LWP 26524)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc5ec2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#2  0x08112708 in ?? ()
#3  0x08114d2c in ?? ()
#4  0x08114d6c in ?? ()
#5  0x0812783f in ?? ()
#6  0x080cf501 in ?? ()
#7  0x01efef42 in ?? ()
#8  0x053fccb0 in ?? ()
#9  0xffffffff in ?? ()
#10 0x09e57890 in ?? ()
#11 0x09e57890 in ?? ()
#12 0x01eff06d in ?? ()
#13 0x00020100 in ?? ()
#14 0x053fcc78 in ?? ()
#15 0x053fccb0 in ?? ()
#16 0x00000001 in ?? ()
#17 0x03d0e1fc in ?? ()
#18 0x01efef1c in ?? ()
#19 0x03d0e214 in ?? ()
#20 0x01efee26 in ?? ()
#21 0x053fccb0 in ?? ()
#22 0xffffffff in ?? ()
#23 0x0543b790 in ?? ()
#24 0x09d429c8 in ?? ()
#25 0x03d0e254 in ?? ()
#26 0x01efed46 in ?? ()
#27 0x053fccb0 in ?? ()
#28 0x00d429c8 in pango_font_description_get_set_fields@plt ()
   from /usr/lib/libgailutil.so.18
#29 0x00000000 in ?? ()

Thread 2 (Thread 0x67a1b90 (LWP 26553)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00cc5b95 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x013f20d7 in _xcb_wait_io (c=<value optimized out>, 
    cond=<value optimized out>) at xcb_conn.c:303
#3  0x013f2fbf in xcb_send_request (c=<value optimized out>, 
    flags=<value optimized out>, vector=<value optimized out>, 
    req=<value optimized out>) at xcb_out.c:193
#4  0x0118ac56 in _XPutXCBBuffer (dpy=<value optimized out>) at xcb_lock.c:148
#5  0x0118b020 in _XCBUnlockDisplay (dpy=<value optimized out>)
    at xcb_lock.c:31
#6  0x0118104a in XUnmapWindow (dpy=<value optimized out>, 
    w=<value optimized out>) at UnmapWin.c:43
#7  0x011819b2 in XWithdrawWindow (dpy=) at Withdraw.c:75
#8  0x05ad239c in gdk_window_withdraw () from /usr/lib/libgdk-x11-2.0.so.0
#9  0x0467a4f3 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#10 0x0a04e6a0 in ?? ()
#11 0x093fb200 in ?? ()
#12 0x067a0718 in ?? ()
#13 0x02255d6c in g_value_peek_pointer () from /lib/libgobject-2.0.so.0
#14 0x022418b4 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#15 0x022328a9 in ?? () from /lib/libgobject-2.0.so.0
#16 0x0223412b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#17 0x022481ee in ?? () from /lib/libgobject-2.0.so.0
#18 0x02249ece in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#19 0x0224a336 in g_signal_emit () from /lib/libgobject-2.0.so.0
#20 0x04665d30 in gtk_widget_unmap () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x0467a1fe in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x0948c860 in ?? ()
#23 0x087d0952 in ?? ()
#24 0x093fbb38 in ?? ()
#25 0x0226a67c in ?? () from /lib/libgobject-2.0.so.0
#26 0x0226a67c in ?? () from /lib/libgobject-2.0.so.0
#27 0x0948c860 in ?? ()
#28 0x067a0c08 in ?? ()
#29 0x022418b4 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
Backtrace stopped: frame did not save the PC

Thread 1 (Thread 0x113cc0 (LWP 25889)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00bb97bb in __libc_fork () at ../nptl/sysdeps/unix/sysv/linux/fork.c:127
#2  0x00ccb2b4 in __fork () at ../nptl/sysdeps/unix/sysv/linux/pt-fork.c:26
#3  0x002730d5 in ?? () from /lib/libglib-2.0.so.0
#4  0x00273c0e in g_spawn_sync () from /lib/libglib-2.0.so.0
#5  0x002740dc in g_spawn_command_line_sync () from /lib/libglib-2.0.so.0
#6  0x08179775 in ?? ()
#7  <signal handler called>
#8  0x00110416 in __kernel_vsyscall ()
#9  0x00b49660 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#10 0x00b4b028 in abort () at abort.c:88
#11 0x00b4257e in __assert_fail (assertion=<value optimized out>, 
    file=<value optimized out>, line=<value optimized out>, 
    function=<value optimized out>) at assert.c:78
#12 0x0118af14 in _XGetXCBBuffer (dpy=<value optimized out>) at xcb_lock.c:77
#13 0x0118c2f3 in _XSend (dpy=<value optimized out>, 
    data=<value optimized out>, size=<value optimized out>) at xcb_io.c:239
#14 0x0118c4b2 in _XFlush (dpy=) at xcb_io.c:258
#15 0x01163b41 in XFlush (dpy=<value optimized out>) at Flush.c:41
#16 0x05aac384 in gdk_display_flush () from /usr/lib/libgdk-x11-2.0.so.0
#17 0x05aa312c in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#18 0x0919e010 in ?? ()
#19 0x0a0351d8 in ?? ()
#20 0x00000004 in ?? ()
#21 0x09bb4500 in ?? ()
#22 0x09bb4500 in ?? ()
#23 0x05b03b80 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#24 0xbf8b6cb8 in ?? ()
#25 0x05aa3244 in gdk_window_process_all_updates ()
   from /usr/lib/libgdk-x11-2.0.so.0
Backtrace stopped: frame did not save the PC


=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

abort
Comment 1 Nigel Jones 2008-07-12 02:26:21 EDT
I can confirm this on x86_64, thank you for reporting it.
Comment 2 Nigel Jones 2008-07-12 05:37:46 EDT
(In reply to comment #1)
> I can confirm this on x86_64, thank you for reporting it.

It looks like this is fixed in 0.4.3 which I'll be pushing for Fedora 9 shortly.

I should have an RPM for testing soon.
Comment 3 Fedora Update System 2008-07-14 07:23:13 EDT
f-spot-0.4.3.1-1.fc9 has been submitted as an update for Fedora 9
Comment 4 Nigel Jones 2008-07-14 07:36:07 EDT
I'd really appreciate it if you could test this when the next testing push 
occurs, in the mean time, you can grab a copy of the RPM from http://
kojipkgs.fedoraproject.org/packages/f-spot/0.4.3.1/1.fc9/
Comment 5 Fedora Update System 2008-07-15 08:19:15 EDT
f-spot-0.4.3.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update f-spot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6313
Comment 6 Fedora Update System 2008-07-23 03:14:02 EDT
f-spot-0.4.3.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Dominik Sandjaja 2009-04-02 05:08:39 EDT
Reproducable on latest F10 with updates-testing enabled (happened without -testing, too). But happens at exporting to cd.

See my comment here:
http://bugzilla.gnome.org/show_bug.cgi?id=533200#c3

Note You need to log in before you can comment on or make changes to this bug.