Bug 448309 - mount.cifs fails to mount samba share
mount.cifs fails to mount samba share
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 15:13 EDT by Dinesh Joshi
Modified: 2014-06-18 03:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 11:07:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dinesh Joshi 2008-05-25 15:13:25 EDT
Description of problem:
I made a clean install of Fedora 9 since then the same command to mount samba
shares off my server running CentOS 5 doesn't work. The share is a public share
accessible via the guest user account ( no authentication required ). When I try
to mount it using the command:

mount -t cifs \\IPADDRESS\SHARENAME /mnt/smbshare

I get the error "mount error 20 = Not a directory" while infact the share exists
and the mount point also exists. SELinux is disabled on both the server and
client ( running F9 ). I tried mounting the share on a F8 machine using the same
command. It worked perfectly.

I would also like to mention that I can browse the share normally via Konqueror
or Nautilus. When I enter the URL with the same path i.e.
smb://IPADDRESS/SHARENAME, it works as expected. No issues there.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always reproducible

Steps to Reproduce:
1. Open a shell ( konsole / gnome-terminal )
2. Get super user privileges using "su -"
3. run -> mount -t cifs \\IPADDRESS\SHARENAME /mnt/smbshare ( after replacing
IPADDRESS and SHARENAME with the appropriate values ).
  
Actual results:
The mount command fails with the following error:

mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)



Expected results:
The share should be mounted

Additional info:
1. Fedora 8 machine is able to mount the share with exactly the same command.
2. Firewall on both server and client were disabled and tested. The problem
persisted.
3. The shares mount properly on windows machines.
4. The share can be browsed on the Fedora 9 machine using konqueror and nautilus
as well as the smbclient command from CLI.
Comment 1 Eric Doutreleau 2008-06-23 05:15:25 EDT
I got the same problems but with a share with authentication.
i can accest it with smbclient but not with mount -t cifs
Comment 2 Jeff Layton 2008-11-06 09:02:59 EST
Are you still seeing this with more recent kernel/mount.cifs programs? I believe this is now fixed upstream.
Comment 3 Jeff Layton 2009-01-22 11:07:39 EST
No word on this in quite some time. Closing as CURRENTRELEASE since I believe this is now fixed. Please reopen if it isn't.

Note You need to log in before you can comment on or make changes to this bug.