Bug 448315 - unable to name radio station
unable to name radio station
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnomeradio (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 15:54 EDT by Mladen Kuntner
Modified: 2008-11-26 01:20 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:20:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mladen Kuntner 2008-05-25 15:54:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
It is not possible to name a station.

When the input field loses focus we get:

** gnomeradio:ERROR:(prefs.c:424):name_cell_edited_cb: assertion failed: (mom_ps < g_list_length(menuitems))

Version-Release number of selected component (if applicable):
gnomeradio-1.7-5.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1. start gnomeradio
2. click "Edit your preferences button"
3. click "+add"
4. click "unnamed" and type name of the station
5. click on frequency column to change frequency

Actual Results:
gnomeradio exits with:

** gnomeradio:ERROR:(prefs.c:424):name_cell_edited_cb: assertion failed: (mom_ps < g_list_length(menuitems))

Expected Results:
gnomeradio should save changes

Additional info:
guessing from the rest of the code:

could we add 

mom_ps = *row;

before

preset_combo_set_item(mom_ps);

in function - name_cell_edited_cb
Comment 1 Dominik 'Rathann' Mierzejewski 2008-10-31 12:28:34 EDT
Sorry for the long delay, I didn't have the necessary hardware to reproduce this. The bug is now confirmed, I'll see what I can do about a solution.
Comment 2 Dominik 'Rathann' Mierzejewski 2008-10-31 13:31:54 EDT
Looks like it's fixed in 1.8. I'll issue an update soon.
Comment 3 Fedora Update System 2008-11-04 20:21:16 EST
gnomeradio-1.8-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnomeradio-1.8-1.fc10
Comment 4 Fedora Update System 2008-11-04 20:21:21 EST
gnomeradio-1.8-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gnomeradio-1.8-1.fc9
Comment 5 Fedora Update System 2008-11-04 20:26:02 EST
gnomeradio-1.8-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnomeradio-1.8-1.fc10
Comment 6 Fedora Update System 2008-11-06 21:56:47 EST
gnomeradio-1.8-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnomeradio'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-9471
Comment 7 Fedora Update System 2008-11-06 21:57:43 EST
gnomeradio-1.8-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnomeradio'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9486
Comment 8 Fedora Update System 2008-11-26 01:11:35 EST
gnomeradio-1.8-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-11-26 01:20:13 EST
gnomeradio-1.8-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.