Bug 448316 - Sound skips under CPU-heavy operations (Intel ICH8)
Sound skips under CPU-heavy operations (Intel ICH8)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 16:37 EDT by Stewart Adam
Modified: 2008-09-19 10:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-19 10:38:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2008-05-25 16:37:09 EDT
Description of problem:
When doing something CPU-intensive (especially when CPU usage spikes), audio
playback skips or halts for roughly half a second then continues. This happens
when using alsa or pulseaudio.

Version-Release number of selected component (if applicable):
alsa-utils-1.0.16-2.fc9.x86_64
python-alsaaudio-0.3-1.fc9.x86_64
alsa-lib-1.0.16-3.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64
pulseaudio-utils-0.9.10-1.fc9.x86_64
pulseaudio-module-x11-0.9.10-1.fc9.x86_64
pulseaudio-libs-glib2-0.9.10-1.fc9.x86_64
pulseaudio-0.9.10-1.fc9.x86_64
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
pulseaudio-libs-zeroconf-0.9.10-1.fc9.x86_64
pulseaudio-libs-0.9.10-1.fc9.x86_64
pulseaudio-esound-compat-0.9.10-1.fc9.x86_64
pulseaudio-core-libs-0.9.10-1.fc9.x86_64
pulseaudio-module-gconf-0.9.10-1.fc9.x86_64
pulseaudio-module-zeroconf-0.9.10-1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open rhythmbox
2. Begin to compile boost from SRPM
3. Play music
  
Actual results:
Playback halts or skips for 1/2 a second, then resumes at seemingly random
intervals. However, this behaviour stops if one isn't doing something CPU-heavy
(scrolling in firefox)

Expected results:
Audio is smooth

Additional info:
I don't have DRI since I'm on a Radeon HD 3850 at the moment. I've experienced
this with the vesa, radeon and radeonhd drivers but I never noticed this problem
when using an nVidia card (proprietary drivers) on this same machine. So maybe
it has something to do with kernel 2.6.24, 2.6.25 or the lack of DRI?

Hardware:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
Comment 1 Stewart Adam 2008-05-31 13:41:15 EDT
Scratch the DRI idea, I tried downgrading X + fglrx driver and the problem still
occurred.

It seems to be much easier to reproduce when using gedit and a terminal at once
(ie lots of saving, alt+tab, run program, edit a bit, save, alt+tab, run program)
Comment 2 Martin Stransky 2008-06-02 09:25:13 EDT
Why do you think it's an alsa-lib problem? Can you try to disable pulse audio?
Comment 3 Stewart Adam 2008-06-02 19:08:31 EDT
I tried already by running "pulseaudio -k" and then restarting rhythmbox and the
problem still occurred - Do I have to disable it in the gnome sound preferences
as well?
Comment 4 Martin Stransky 2008-06-03 04:06:38 EDT
Try to run some sound application what uses ALSA directly (mplayer for instance)
and ensure that the audio application doesn't use the pulse-audio plugin (so
comment out the pulse-plugin line from /etc/alsa/alsa.conf).
Comment 5 Stewart Adam 2008-06-03 16:44:30 EDT
Confirmed with alsa.
Comment 6 Martin Stransky 2008-06-03 16:54:23 EDT
Ehm, could you be more specific?
Comment 7 Stewart Adam 2008-06-03 18:12:00 EDT
Sorry, I meant that the audio still skiped when playing with mplayer (I also
commented out the line in alsa.conf as well).
Comment 8 Stewart Adam 2008-06-22 16:40:01 EDT
Do you have any ideas as to what could cause the problem?
Comment 9 Alexander Gavrilov 2008-09-19 10:05:38 EDT
Please look at my analysis of recent pulseaudio crashes, that I attached to the following bug:

https://bugzilla.redhat.com/show_bug.cgi?id=462200

Since they occur during CPU-intensive operations, simultaneously to glitches in playback, they might be related to this bug. I'm not an expert on ALSA, but it looks like a kernel driver problem to me.

There is also a workaround patch that makes the crashes (but not the glitches) go away.
Comment 10 Stewart Adam 2008-09-19 10:38:31 EDT
I think these are two different problems - A while back I spoke to a developer about this problem on the alsa-devel mailing list and wrote a quick patch that solved all the problems. I'm not using kernel 2.6.26 though, so that may be why I'm not getting the problem you're describing.

In any case, I'll close this one since my sound hasn't glitched in near 3 months now.

Note You need to log in before you can comment on or make changes to this bug.