Bug 448324 - opyum requires python module pirut
opyum requires python module pirut
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: opyum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 17:30 EDT by Maxim
Modified: 2008-07-16 15:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 15:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Maxim 2008-05-25 17:30:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

Description of problem:
opyum needs Python pirut module, which is not available due to pirut being replaced by PackageKit.

Version-Release number of selected component (if applicable):
opyum-0.0.3-1.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1.install opyum
2.start opyum
3.

Actual Results:
# opyum
Traceback (most recent call last):
  File "/usr/bin/opyum", line 42, in <module>
    from pirut import *
ImportError: No module named pirut

Expected Results:
program start

Additional info:
Comment 1 Debarshi Ray 2008-07-16 15:14:06 EDT
Pirut is no longer a part of Fedora from Fedora 9 onwards. It has been replaced
by PackageKit, and offline package management support is in the works as part of
this year's Google Summer of Code. So very soon it will also replace Opyum.

For the moment, its not possible to use Opyum on Fedora 9 since it had a massive
dependency on Pirut's classes. Yum still allows you to install Opyum because
PackageKit has "Provides: pirut", which is true from a functionality standpoint,
but not from the way Opyum looks at it.

The situation is unfortunate, but we hope to have offline capabilities in
PackageKit sometime soon, and Opyum has been marked as dead in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.