This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 448325 - s-c-d crashes system with "Savage Twister PN133"
s-c-d crashes system with "Savage Twister PN133"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 17:35 EDT by Carl Roth
Modified: 2008-06-14 14:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 14:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 2008-05-25 17:35:23 EDT
Description of problem:

I was trying to configure a text-mode system into a graphical system containing
a "Savage Twister PN133" chipset.  I had an empty xorg.conf file, and I ran
s-c-d to detect/configure the display.  I found that

1. s-c-d could not detect the graphics chipset properly (even though the
'savage' xorg driver RPM was installed
2. s-c-d could not identify the monitor resolution
3. when i selected any of the xorg drivers (including the correct one, 'savage')
and quit s-c-d, the machine locked up and required a power-cycle.

Version-Release number of selected component (if applicable):

system-config-display-1.0.51-9.fc9.noarch
xorg-x11-drv-savage-2.2.0-2.fc9.i386

How reproducible:


Steps to Reproduce:
1. Set the system to text mode (runlevel 3)
2. Delete xorg.conf
3. Run s-c-d
  
Actual results:

System crashes when s-c-d exits

Expected results:


Additional info:

After the machine is rebooted, it works OK -- now that the correct xorg driver
is recorded in xorg.conf.  Successive runs of s-c-d then do not crash the system.

Anaconda evidently configures xorg.conf correctly if the system is installed as
a graphical desktop in the first place.  What is that anaconda is doing that
s-c-d is not?
Comment 1 Matěj Cepl 2008-06-02 18:24:50 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Carl Roth 2008-06-14 14:26:15 EDT
I can't reproduce this bug.  I deleted the xorg.conf file and s-c-d and xorg
worked as advertised, filling in the driver as 'savage' and failing to crash, of
course.  Unfortunately I don't have the previous xorg.conf file, which may have
had an incompatible driver section in it.

Sorry for the trouble.

Note You need to log in before you can comment on or make changes to this bug.