Bug 448332 - Resizing video in firefox makes trash bin open
Resizing video in firefox makes trash bin open
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 20:00 EDT by Jonas Nyman
Modified: 2018-04-11 11:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-29 09:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (336.34 KB, image/png)
2008-05-25 20:00 EDT, Jonas Nyman
no flags Details
screen shot with erratic mplayer message (188.77 KB, image/png)
2008-05-28 09:11 EDT, Jonas Nyman
no flags Details

  None (edit)
Description Jonas Nyman 2008-05-25 20:00:46 EDT
Description of problem:
Watching a .asx video stream in mozilla firefox 3b5 with gecko media player plug
in 0.6.1 makes trash bin folder open when resizing video window. 

Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Open mozilla firefox, have gecko-media-plug-in installed.
2. Watch a .asx video stream in full screen.
3. Resize to non-full screen.
  
Actual results:
Trash bin opens for no reason

Expected results:
Trash bin should not open.

Additional info:
Fully updated Fedora 9. firefox-3.0-0.60.beta5.fc9.x86_64
gecko-media-player 0.6.1, 
mplayer-1.0-0.93.20080211svn.lvn9.x86_64
gnome-mplayer-0.6.1-1.lvn9.x86_64
Comment 1 Jonas Nyman 2008-05-25 20:00:46 EDT
Created attachment 306636 [details]
screen shot
Comment 2 Matěj Cepl 2008-05-26 12:06:20 EDT
Hmm, I have a bit problem with this:

a) http://www.nasa.gov/55644main_NASATV_Windows.asx doesn't play for me at all
-- neither with embedded Totem player, nor with standalone totem, nor either
with mplayer,
b) it is not possible to play the stream just with software provided officially
by the Fedora -- there is no way how we can play some elements of the stream
without installing plugins from other third part repositories.
c) Could you reproduce this with known-to-be-working videos like
http://www.redhat.com/v/ogg/TruthHappens.ogg?
Comment 3 Jonas Nyman 2008-05-26 16:00:30 EDT
Yes, it is 100% reproducible with  http://www.redhat.com/v/ogg/TruthHappens.ogg

NASA TV might not work now, I was watching the landing of the Phoenix space craft...

As I clearly(?) stated above, the mplayer and gnome-mplayer packages are from
livna. However, I assumed it is Fedora 9-related, as I have never seen this
behaviour before I upgraded to F9. 

Can you reproduce this with native Fedora software only and known-to-be working
video?
Comment 4 Matěj Cepl 2008-05-27 07:15:37 EDT
No, I cannot -- before I wrote comment 2 (of course) I enjoyed Truth Happens
again. Catching after straws here -- could you yum remove \*mplayer\* and try
Truth Happens again? Anything interesting with package-cleanup --problems (it is
from yum-utils package)?
Comment 5 Jonas Nyman 2008-05-28 09:11:50 EDT
Created attachment 306929 [details]
screen shot with erratic mplayer message

Mplayer erroneously claims it can not load codec.
Comment 6 Jonas Nyman 2008-05-28 09:14:04 EDT
Package-cleanup --problems renders no problems, as expected, it is a fairly
fresh install...

I did as you asked me:

Removing:
 gnome-mplayer           x86_64     0.6.1-1.lvn9   
 mplayer                 x86_64     1.0-0.93.20080211svn.lvn9       
 mplayer-doc             x86_64     1.0-0.93.20080211svn.lvn9  
 mplayer-gui             x86_64     1.0-0.93.20080211svn.lvn9  
Removing for dependencies:
 gecko-mediaplayer       x86_64     0.6.1-1.lvn9     
 mencoder                x86_64     1.0-0.93.20080211svn.lvn9  

I then installed them again, one by one trying to figure out when I can
reproduce bug and when I can't. 

It is clear that it is gecko-mediaplayer that is responsible. 
Without this installed, the videos can be viewed in mplayer running as stand
alone program. The bug is not reproducible under such conditions. 


However, install gecko-mediaplayer and the videos will be streamed and viewed in
firefox.  This makes trash bin opens when downsizing from full screen. 

I may have found an other bug in mplayer, but I'm not sure yet.
I got an error message "Error! Could not load codec" despite the movie and sound
working perfectly... See screen shot.
Comment 7 Matěj Cepl 2008-07-29 09:59:35 EDT
OK, so let's make this clear. If the problem is in plain totem (Truth Happens
should be playable without any packages from third party repositories), then we
can do something about it. If the problem is in gecko-mediaplayer (or any
package which we don't support), then you should file a bug to the appropriate
bugzilla elsewhere.

Closing as NOTABUG (in our packages, that is). Please, reopen with additional
information, if you can reproduce this just with Fedora-provided packages on OGG
video.

Note You need to log in before you can comment on or make changes to this bug.