Bug 448338 - Tries to open shell scripts
Tries to open shell scripts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 20:32 EDT by Bastien Nocera
Modified: 2009-05-09 13:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 04:31:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-05-25 20:32:50 EDT
wine-0.9.58-1.fc9.i386

Double-clicking on an shell script in nautilus would try to open Wine by
default, because text/x-shellscript is a descendant of application/x-executable.

Nowadays, only ELF files, and shell scripts are (or are descendants of)
application/x-executable.

Please remove application/x-executable from the fedora-wine.desktop file
(probably to do in F8, F9 and rawhide).

See also:
https://bugs.freedesktop.org/show_bug.cgi?id=12569
which was fixed in shared-mime-info 0.30 (I'm happy to do the shared-mime-info
updates if it creates regressions in F8).
Comment 1 Fedora Update System 2008-06-17 15:37:00 EDT
wine-docs-1.0-1.fc9 has been submitted as an update for Fedora 9
Comment 2 Fedora Update System 2008-06-17 15:41:07 EDT
wine-docs-1.0-1.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-06-17 15:42:06 EDT
wine-docs-1.0-1.fc7 has been submitted as an update for Fedora 7
Comment 4 Fedora Update System 2008-06-20 15:08:02 EDT
wine-1.0-1.fc8, wine-docs-1.0-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine wine-docs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5488
Comment 5 Fedora Update System 2008-06-26 04:31:10 EDT
wine-1.0-1.fc9, wine-docs-1.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-06-26 04:34:32 EDT
wine-1.0-1.fc8, wine-docs-1.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.