Bug 448340 - X works only once.
X works only once.
Status: CLOSED DUPLICATE of bug 241498
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 21:20 EDT by Björn Persson
Modified: 2008-09-09 16:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 16:56:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of the first X (21.01 KB, text/plain)
2008-05-25 21:20 EDT, Björn Persson
no flags Details
log of the second X (14.30 KB, text/plain)
2008-05-25 21:21 EDT, Björn Persson
no flags Details
/etc/xorg.conf (674 bytes, text/plain)
2008-05-25 21:22 EDT, Björn Persson
no flags Details

  None (edit)
Description Björn Persson 2008-05-25 21:20:17 EDT
Description of problem:
When the system boots in runlevel 5, the screen goes blank when it's supposed to
change from RHGB to the login screen. Then the monitor goes to sleep. The system
doesn't react to keypresses; I can't even get it to switch virtual consoles. By
logging in by SSH I can see that everything else is working fine. Only the
console is unresponsive.

As far as I can tell from the logs, two instances of X start even though I have
only one graphics controller and one monitor. One crashes and logs a backtrace.
The other stays alive but complains about errors in the hardware state and
doesn't display anything on the screen.

The problem seems to occur only when initdefault is 5. If I let the system boot
in runlevel 3 and then run telinit 5, then only one X starts and it works
normally. Therefore I guess that the problem is in Upstart, but I may be wrong.

Version-Release number of selected component (if applicable):
upstart-0.3.9-19.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot in runlevel 5.
2. Watch the initscripts run.
  
Actual results:
The screen goes black and won't even switch virtual consoles.

Expected results:
the GDM login screen

Additional info:
This is a fully updated Fedora 9 upgraded from Fedora 8 (where I didn't have
this problem).
The graphics controller is the X3500 inside Intel's G35 chip on an Asus P5E-V
HDMI motherboard. X uses the driver "intel".
Connecting the monitor by DVI or VGA makes no difference.
Comment 1 Björn Persson 2008-05-25 21:20:17 EDT
Created attachment 306637 [details]
log of the first X
Comment 2 Björn Persson 2008-05-25 21:21:52 EDT
Created attachment 306638 [details]
log of the second X
Comment 3 Björn Persson 2008-05-25 21:22:52 EDT
Created attachment 306639 [details]
/etc/xorg.conf
Comment 4 Björn Persson 2008-05-26 18:56:53 EDT
Here's an additional observation. As noted above, I can get a working desktop by
booting in runlevel 3 and then switching to runlevel 5. Now, if I log out from
that desktop and X is supposed to restart, then two instances of X start again
and the result is a blank screen just like when I boot in runlevel 5.
Comment 5 Bill Nottingham 2008-05-27 11:02:39 EDT
Assigning to GDM for now.
Comment 6 Björn Persson 2008-09-06 11:50:55 EDT
I think I've found out why booting in runlevel 3 made a difference. I discovered that booting in runlevel 5 works if I remove "rhgb" from the Linux command line, and RHGB also doesn't run when the default runlevel is 3. X still doesn't restart properly when I log out. Thus it seems like X works only if X hasn't run before since the machine was booted.

I originally thought that two instances of X were started at once. I'm not so sure about that anymore. It may have been that X was started, crashed and was restarted within the same second.
Comment 7 Matěj Cepl 2008-09-09 16:56:39 EDT

*** This bug has been marked as a duplicate of bug 241498 ***

Note You need to log in before you can comment on or make changes to this bug.