Bug 448347 - FIle conflict of /usr/bin/ebb with dvipdfmx
FIle conflict of /usr/bin/ebb with dvipdfmx
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dvipdfm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 02:19 EDT by Mamoru TASAKA
Modified: 2008-07-21 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 12:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-05-26 02:19:42 EDT
Description of problem:
[root@localhost i386]# rpm -q dvipdfm dvipdfmx
dvipdfm-0.13.2d-38.fc9.i386
dvipdfmx-0-0.20.20071115cvs.fc9.i386
[root@localhost i386]# rpm -qf /usr/bin/ebb
dvipdfm-0.13.2d-38.fc9.i386
[root@localhost i386]# ls -al dvipdfm*rpm
-rw-r--r-- 1 root root 304871 May 11 09:43 dvipdfm-0.13.2d-38.fc9.i386.rpm
-rw-r--r-- 1 root root 304875 May 11 09:38 dvipdfm-0.13.2d-38.fc10.i386.rpm
-rw-r--r-- 1 root root 398303 Mar  8 08:45 dvipdfmx-0-0.20.20071115cvs.fc9.i386.rpm
-rw-r--r-- 1 root root 381134 May 26 15:09 dvipdfmx-0-0.22.20080520cvs.fc10.i386.rpm
[root@localhost i386]# rpm -Fvh --test dvipdfm*rpm
Preparing...                ########################################### [100%]
        file /usr/bin/ebb conflicts between attempted installs of
dvipdfmx-0-0.22.20080520cvs.fc10.i386 and dvipdfm-0.13.2d-38.fc10.i386


Version-Release number of selected component (if applicable):
dvipdfm-0.13.2d-38.fc10
dvipdfmx-0-0.22.20080520cvs.fc10

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
Comment 1 Jonathan Underwood 2008-05-26 06:28:33 EDT
Ah, yes, thanks for the report. I'll compare the two ebb programs and see if
there's any differences. This is the problem with packaging two forked
codebases, alas. [Aside: at some point I think we should drop dvipdfm, but I'm
not sure that now is the right time.]
Comment 2 Jonathan Underwood 2008-05-26 08:55:09 EDT
Ok, have added a patch to the dvipdfmx package which renames ebb to ebbx. This
is included in package 0-0.23.20080520cvs

http://koji.fedoraproject.org/koji/taskinfo?taskID=628805
Comment 3 Jonathan Underwood 2008-05-26 09:41:32 EDT
I contacted the upstream dvipdfmx maintainer about this, and the following is
his reply:

Thanks for your report. Actually there were two bounding box extraction
utilities, ebb and xbb.

As you might know, ebb is quite old and it is not useful in these days
because it does not support pdf files with version 1.4 or higher.
Moreover, the bounding box calculated by ebb from JPEG or PNG makes
different size figures as compared to the result by pdfTeX.
So we made a new bounding box extraction program xbb.

Recently, Karl Berry, the maintainer of TeXLive suggested to combine
those programs into dvipdfmx. He wanted just one executable, and the
name of the new extraction utility became "extractbb". It behaves as xbb
and with "-m" option, it behaves as ebb (but more powerful).

Anyway, as I guess, Karl wanted to remove the original (buggy) ebb
from TeXLive. So there may be no problem with TeXLive. Moreover, I do
not want the name "ebbx". If you want to remain the original "ebb". Just
do not make the link, because if someone wants a new ebb, he can use
"extractbb -m" instead.

Note You need to log in before you can comment on or make changes to this bug.