Bug 448351 - directfb application segfaults randomly
directfb application segfaults randomly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: directfb (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 02:37 EDT by Russell Miller
Modified: 2008-10-27 14:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 14:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Miller 2008-05-26 02:37:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
I wrote a program for directfb that worked fine under i386 architecture.  However, under x86_64, it apears to randomly segfault.  It ALWAYS segfaults at dfb_config_init, conf.c:1274.

gdb shows that all of the variables being passed in are being "optimized out".  This is probably why the segfault is occurring, argv, argc, *and* i are being optimized out.  I am not running gcc with any optimization flags.

a related problem that I may need to open another bug for, is that gdb refuses to read the symbols in the program I compiled - it seems to only use the ones from the debuginfo.  If I try to load the object files manually, it says "the address where <file> has been loaded is missing".

The really befuddling part is - it only doesn't work *sometimes*.  A few times, the program will start.

There are no hardware or memory issues that I'm aware of, I just built the machine three days ago.

Version-Release number of selected component (if applicable):
directfb-1.0-0

How reproducible:
Sometimes


Steps to Reproduce:
1. Write a program using directfb, and pass argc and argv in to the init routine.
2. ???? *
3. Crash.

* south park reference, there is no step 2.

Actual Results:
segfault.

Expected Results:
no segfault.

Additional info:
stock fedora install.
Comment 1 Nicolas Chauvet (kwizart) 2008-10-23 07:41:50 EDT
FYI directfb has been updated to 1.2.6 in Rawhide.
You might want to test against this newer version.

Actually it should be possible to downgrade the release field when building directfb. So it will have the same SONAME as the current F-9 1.0.0 version.
Comment 2 Nicolas Chauvet (kwizart) 2008-10-27 14:45:05 EDT
I'm closing this bug to rawhide as there is low chances to have the package updated because of the ABI bump.

Note You need to log in before you can comment on or make changes to this bug.