Bug 448360 - I got a signal 11
I got a signal 11
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: WindowMaker (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 04:48 EDT by acount closed by user
Modified: 2008-07-26 02:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.92.0-18.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 23:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file for gcc 4.x compatibility (5.09 KB, patch)
2008-07-01 21:30 EDT, Srinath Madhavan
no flags Details | Diff
configure script log (9.91 KB, application/octet-stream)
2008-07-01 21:31 EDT, Srinath Madhavan
no flags Details
make log (65.00 KB, application/octet-stream)
2008-07-01 21:31 EDT, Srinath Madhavan
no flags Details
make install log (48.14 KB, application/octet-stream)
2008-07-01 21:32 EDT, Srinath Madhavan
no flags Details

  None (edit)
Description acount closed by user 2008-05-26 04:48:22 EDT
WindowMaker in Fedora 9 always gets a "signal 11"

-thanks-
Comment 1 Srinath Madhavan 2008-06-01 15:43:08 EDT
I solved this problem by rebuilding WindowMaker from source. Before the build, I
had to patch the source to ensure compatibility with gcc 4.3.
Comment 2 Andreas Bierfert 2008-06-17 05:32:20 EDT
Could you attach the patch?
Comment 3 Habig, Alec 2008-06-18 00:22:37 EDT
Verified the problem by trying to run windowmaker from a fresh account, in case
it was something with my existing conf files.  No dice, always a signal 11 a
fraction of a second after starting the initial draw of the desktop.

Aha, I found further info from Srinath here:

  http://www.fedoraforum.org/forum/showthread.php?t=188334

which references a patch on a Brazilian linux forum.

Happy to test out anything you can cook up, Andreas!

Comment 4 Petr Machata 2008-06-22 15:09:14 EDT
I can confirm that I've seen this on two independent i386 F 9 installations. 
FWIW rpmbuild from src rpm also fixed the problem for me (I don't even recall
patching for GCC 4.3, but chances are I simply forgot about it).  This is the
stack trace I'm getting, in case it helps...

$ ftrace -f -sig=segv/s -- wmaker
9884.9884 attached /usr/bin/wmaker
9885.9885 attached /usr/bin/wmaker
9886.9886 attached /usr/bin/wmaker
9887.9887 attached /bin/bash
9886.9886 exited with status 0
9887.9887 exited with status 0
9885.9885 signal SIGSEGV
9885.9885 dumping stack trace:
Task #9885
#0 0x08070bf8 in handleExpose ()
#1 0x00152da7 in WMHandleEvent ()
#2 0x0809520f in StartUp ()
#3 0x08078ac8 in main ()
#4 0x004b55d6 in __libc_start_main ()
#5 0x0804f9a1 in _start ()
9885.9885 killed by SIGSEGV(11)
9884.9884 exited with status 1
Comment 5 Petr Machata 2008-06-23 10:01:21 EDT
I tried to do a scratch rebuild:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=676485
and resulting i386 binaries work for me.  Seems like all that's necessary is
simple bump & rebuild.  And no patch seems to be necessary for GCC 4.3.
Comment 6 acount closed by user 2008-06-23 11:23:17 EDT
it works for me.

THANKS
Comment 7 Petr Machata 2008-06-24 09:07:19 EDT
Reopening the bug, stock Fedora 9 WindowMaker still sigsegvs.
Comment 8 Srinath Madhavan 2008-07-01 17:29:51 EDT
Andreas: My sincere apologies for not having responded in a timely fashion. I've
been running WindowMaker on F9 (built from source). It is very very stable :-)

As mentioned earlier, there is a patch that needs to be applied in order to get
it to build with Gcc 4.3. Also there is another issue with a missing symbolic
link that causes WPrefs to load without the tiff pixmaps for the buttons. I've
reported these on forums.fedoraforum.org.

Since the configure, make and make install logs are in my laptop at home, I will
post the instructions here tonight. Once again very sorry for not having responded.
Comment 9 Srinath Madhavan 2008-07-01 21:30:19 EDT
Created attachment 310742 [details]
Patch file for gcc 4.x compatibility

The original patch source is here -->
http://translate.google.ca/translate?hl=en&sl=pt&u=http://www.vivaolinux.com.br/dicas/verDica.php%3Fcodigo%3D10364&sa=X&oi=translate&resnum=5&ct=result&prev=/search%3Fq%3D%2522can%2527t%2Bfind%2Ba%2Bregister%
2Bin%2Bclass%2B%2527GENERAL_REGS%2527%2Bwhile%2522
%2Bwindowmaker%26hl%3Den%26sa%3DG
Comment 10 Srinath Madhavan 2008-07-01 21:31:03 EDT
Created attachment 310743 [details]
configure script log

Window Maker configure log.
Comment 11 Srinath Madhavan 2008-07-01 21:31:37 EDT
Created attachment 310744 [details]
make log

make log
Comment 12 Srinath Madhavan 2008-07-01 21:32:04 EDT
Created attachment 310745 [details]
make install log

make install log
Comment 13 Srinath Madhavan 2008-07-01 21:40:01 EDT
Instructions:

tar xzvf WindowMaker-0.92.0.tar.gz
patch WindowMaker-0.92.0/wrlib/x86_specific.c < windowmaker-gcc4.patch.txt
./configure --x-includes=/usr/include/X11/ --x-libraries=/usr/lib/ >
configure.log 2>&1
make > make.log 2>&1
make install > make_install.log 2>&1

After Window Maker is installed, it seems that the WPrefs utility is unable to
find the installed pixmaps necessary for the buttons. This can be easily fixed
by creating an appropriate symbolic link as discussed here[1]

References:

[1]  http://fedoraforum.org/forum/showthread.php?t=188334
Comment 14 Srinath Madhavan 2008-07-01 22:36:43 EDT
Just an FYI: The official Window Maker webpage (http://windowmaker.info/) just
came online today!
Comment 15 Petr Machata 2008-07-02 04:40:15 EDT
Madhavan, the patch is not necessary, I've already done a scratch build to prove
that.  Also, is there a reason you are building from source, instead from cvs
checkout or src rpm?

Anyway, lack of action on Andreas' side makes me think that perhaps he is in a
serious shortage of personal time right now, so I dared to step ahead and do a
bump and rebuild myself.  I hope that it's not a problem.
Comment 16 Fedora Update System 2008-07-02 04:41:05 EDT
WindowMaker-0.92.0-18.fc9 has been submitted as an update for Fedora 9
Comment 17 Srinath Madhavan 2008-07-02 11:50:56 EDT
Hi Petr,

When you say CVS do you mean stock Window Maker CVS or the CVS for Fedora 9? If
the src RPM has been updated, I would like to give it a shot.
Comment 18 Petr Machata 2008-07-02 13:51:01 EDT
I meant CVS from Fedora 9.  Mere rebuild, patch-less, was enough to fix
WindowMaker.  It will be great if you try new WindowMaker package as soon as it
hits stable repository!
(Since it's completely broken anyway as it is, I chose to push it to stable
instead of to testing.)
Comment 19 Srinath Madhavan 2008-07-02 14:02:23 EDT
Thanks! Will do.
Comment 20 Fedora Update System 2008-07-02 23:13:43 EDT
WindowMaker-0.92.0-18.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Srinath Madhavan 2008-07-04 00:09:32 EDT
Installed WindowMaker 0.92.0-18 using yum. Running nicely; so far no problems.
Thanks Petr!!
Comment 22 Fedora Update System 2008-07-26 02:10:09 EDT
WindowMaker-0.92.0-18.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.