Bug 448361 - Assertion 'i->thread_info.rewrite_nbytes == 0' failed at pulsecore/sink-input.c:1069
Assertion 'i->thread_info.rewrite_nbytes == 0' failed at pulsecore/sink-input...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-05-26 04:57 EDT by David Nielsen
Modified: 2008-06-26 14:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 14:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2008-05-26 04:57:31 EDT
Description of problem:
If I leave pulseaudio running over night lulling me to sleep with a little audio
goodness there is a 100% chance it will have SIGABRT'ed in the morning. I tried
running it with the -vvv parameter and I capture this prior to the crash.


D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 11996 bytes on render memblockq.
I: module-alsa-sink.c: Underrun!
N: module-alsa-sink.c: Increasing wakeup watermark to 80,00 ms
I: module-alsa-sink.c: Underrun!
N: module-alsa-sink.c: Increasing wakeup watermark to 160,00 ms
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-alsa-sink.c: Requested to rewind 37408 bytes.
D: module-alsa-sink.c: Limited to 708 bytes.
D: module-alsa-sink.c: before: 177
D: module-alsa-sink.c: after: 177
D: module-alsa-sink.c: Rewound 708 bytes.
D: sink.c: Processing rewind...
D: sink-input.c: Have to rewind 708 bytes on render memblockq.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-alsa-sink.c: Requested to rewind 37408 bytes.
D: module-alsa-sink.c: Mhmm, actually there is nothing to rewind.
I: module-alsa-sink.c: Underrun!
N: module-alsa-sink.c: Increasing wakeup watermark to 177,01 ms
D: protocol-native.c: Requesting rewind due to end of underrun.
D: module-alsa-sink.c: Requested to rewind 26108 bytes.
D: module-alsa-sink.c: Mhmm, actually there is nothing to rewind.
D: protocol-native.c: Requesting rewind due to end of underrun.
E: sink-input.c: Assertion 'i->thread_info.rewrite_nbytes == 0' failed at
pulsecore/sink-input.c:1069, function pa_sink_input_request_rewind(). Aborting.
Afbrudt (SIGABRT)

Version-Release number of selected component (if applicable):
pulseaudio-0.9.11-0.2.svn20080516.fc10.x86_64
kernel-2.6.26-0.30.rc3.git6.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Leave glitchfree pulseaudio overnight
2. Wake up (this step is rather important)

Actual results:
Notice that pulseaudio decided to display it's glitchfree behavior by crashing.

Expected results:
Continued playing.

Additional info:
Fedora Rawhide, x86_64, da_DK.UTF-8
Comment 1 Lennart Poettering 2008-05-26 15:30:49 EDT
Have you applied the HDA patch as explained in this email?

https://www.redhat.com/archives/fedora-devel-list/2008-May/msg01244.html
Comment 2 David Nielsen 2008-05-26 17:49:03 EDT
Not unless it's in the provided kernel.
Comment 3 David Nielsen 2008-05-28 16:47:37 EDT
Still seeing this with kernel-2.6.26-0.37.rc4.fc10 which has the requested patch
applied.
Comment 4 Lennart Poettering 2008-06-26 14:35:58 EDT
Fixed upstream. I will upload a new version to Rawhide in a few minutes.

Note You need to log in before you can comment on or make changes to this bug.