This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 448363 - clicking download links leads to failure
clicking download links leads to failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-05-26 05:07 EDT by David Nielsen
Modified: 2008-07-01 07:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 07:23:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of reproduction (56.28 KB, image/png)
2008-05-27 17:06 EDT, Matěj Cepl
no flags Details

  None (edit)
Description David Nielsen 2008-05-26 05:07:29 EDT
Description of problem:
When clicking any download link Epiphany spans an error dialog with text like this:

---
/tmp/IQ80mW2+.part could not be saved, because the source file could not be read.

Try again later, or contact the server administrator.
---

Version-Release number of selected component (if applicable):
epiphany-2.22.1.1-1.fc9.x86_64
xulrunner-1.9-0.65.cvs20080416.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install Epiphany on F10
2. click download link
  
Actual results:
Error, download denied

Expected results:
glorious download

Additional info:
Fedora Rawhide, x86_64, da_DK.UTF-8
Comment 1 Matěj Cepl 2008-05-26 09:53:08 EDT
Hmm, weird, cannot reproduce here

epiphany-2.22.1.1-1.fc9.x86_64
xulrunner-1.9-0.65.cvs20080416.fc10.x86_64

Just downloaded
http://sunsite.mff.cuni.cz/pub/fedora/test/9-Preview/Fedora/x86_64/os/Packages/GConf2-2.22.0-1.fc9.i386.rpm
without any problems.

Which URL does break for you? Any more ideas how to reproduce it here?
Comment 2 David Nielsen 2008-05-26 18:28:00 EDT
That one e.g. displays the error.
Comment 3 Matěj Cepl 2008-05-27 07:12:58 EDT
Any backtrace or strace?
Comment 4 David Nielsen 2008-05-27 07:20:57 EDT
no backtrace, it doesn't actually crash, it just spawns that error dialog
instead of downloading the file. No SELinux AVC messages nothing of interest.
Comment 5 Ryan James 2008-05-27 14:51:40 EDT
It only happens if you click something to download.  if you right click > save as or right click > download, it 
will work properly.
Comment 6 David Nielsen 2008-05-27 15:02:01 EDT
yeah but for redirected downloads this workaround is worthless, regardless it
worked before no reason it shouldn't work now
Comment 7 Matěj Cepl 2008-05-27 17:06:24 EDT
Created attachment 306840 [details]
screenshot of reproduction

Oh well, can fully reproduce with the current F9.
Comment 8 David Nielsen 2008-05-27 17:28:28 EDT
odd I only see it on my F10 box, my laptop which runs F9 updated to the latest
updates-testing can download this just fine with a click.
Comment 9 David Nielsen 2008-06-30 20:26:25 EDT
I can no longer reprodcue this in F10 nor on F9. Matej?
Comment 10 Matěj Cepl 2008-07-01 07:23:54 EDT
(In reply to comment #8)
> odd I only see it on my F10 box, my laptop which runs F9 updated to the latest
> updates-testing can download this just fine with a click.

Except I am silly, the screenshot is from Rawhide. And yes, I cannot reproduce
it now with the current Rawhide.

Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.