Bug 448383 - Audacity/ALSA causes kernel bug
Audacity/ALSA causes kernel bug
Status: CLOSED DUPLICATE of bug 443537
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 07:33 EDT by Lyos Gemini Norezel
Modified: 2008-06-06 05:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 05:48:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lyos Gemini Norezel 2008-05-26 07:33:22 EDT
Description of problem:
Audacity will not record more than 1 second of sound. Appears to cause a bug in
the kernel.

Version-Release number of selected component (if applicable):
audacity-nonfree-1.3.4-0.7.20080123cvs.lvn9.i386
(I have noticed that the older 1.3.2-beta version that I also have installed...
does not appear to have this issue.)

alsa:
rpm -qa | grep alsa

alsa-lib-1.0.16-3.fc9.i386
alsamixergui-0.9.0-0.4.rc1.fc9.2.i386
alsa-tools-1.0.16-1.fc9.i386
alsa-utils-1.0.16-2.fc9.i386


How reproducible:
Everytime I use Audacity

Steps to Reproduce:
Not 100% sure... but
1. Run Audacity
2. Edit->Preferences->Quality-> Change to 96000
3. Attempt to record a track.
4. Stop the track anytime after 2 seconds
5. Play the track

These are the steps I've produced this bug with. 
  
Actual results:
Audacity does not appear to record more than 1 second of sound. 
Fedora pops up an alert saying "Your system had a kernel failure".
Audacity appears to still function... though you still cannot record more than 1
second of sound.
dmesg reveals muliple messages of:
"ALSA sound/core/pcm_lib.c:154: BUG: stream = 0, pos = 0x2d41, buffer size =
0x12c0, period size = 0x4b0"

Expected results:
Audacity actually recording a track.

Additional info:
In case it's relevant... here is my lspci output:
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:08.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416)
MPEG-2 Encoder (rev 01)
00:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 05)
00:09.1 Input device controller: Creative Labs SB Live! Game Port (rev 05)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller
(rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge
[KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)
Comment 1 Lyos Gemini Norezel 2008-05-28 03:35:33 EDT
I've recently noticed that this bug seems to cause slow response in KDE/GNOME.
Haven't nailed it down to anything specific... just an overall decrease in
performance after this bug occurs.

Lyos Gemini Norezel
Comment 2 Ben T 2008-06-04 14:42:35 EDT
Suggest directing this to ALSA and/or Audacity.
Comment 3 Chuck Ebbert 2008-06-06 05:45:16 EDT
Bug is assigned to the ALSA maintainer.
Comment 4 Chuck Ebbert 2008-06-06 05:48:30 EDT

*** This bug has been marked as a duplicate of 443537 ***

Note You need to log in before you can comment on or make changes to this bug.