Bug 448412 - Minor errors in RPM documentation
Minor errors in RPM documentation
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: rpm-guide (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Cotton
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 11:47 EDT by Scott Wimer
Modified: 2010-03-06 14:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-06 14:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Wimer 2008-05-26 11:47:39 EDT
Description of problem:

Section 3.2.1.1. Checking That the Package Is Installed
of the RPM documentation
http://docs.fedoraproject.org/drafts/rpm-guide-en/ch03s02.html states that the
'' rpm -q '' command must be given a package name rather than an rpm package
file.  At some point this may have been the case, but thankfully this isn't the
case anymore (CentOS5 rpm version: rpm-4.4.2-47.el5)

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.  Get an RPM file
2.  rpm -q some-rpm.rpm
3.  profit!
  
Actual results:
True statements as to whether or not some-rpm is installed.
And profit (cause the documented "rpm isn't smart enough to open the rpm file
and get the package name" behavior is seriously suboptimal especially since the
package name and the rpm file aren't required to be related).

Expected results:
Documentation says that rpm will halt and catch fire, or fail to work, neither
of which is desirable.

Additional info:

Here's the original text:
"Use the rpm –q command to quickly verify a package has been installed. To
verify, you need to use the name of the installed package, not the name of the
RPM file."

And here's some new text:
"use the rpm -q command to quickly verify a package has been installed.  To
verify, you can either use the name of the installed package, a partial package
name, or the path to an rpm file."
Comment 1 Karsten Wade 2008-06-04 10:25:43 EDT
Moving to the proper (newly minted) component so we can gather and address all
the RPM Guide bugs.
Comment 2 eric@christensenplace.us 2009-07-09 22:21:37 EDT
This guide is being resurrected.  Reassigned all tickets to developer.
Comment 3 Paul W. Frields 2010-03-06 14:49:30 EST
I don't think that comment #1 is correct.  You still need the -p option to query a package file (as opposed to an installed package).

[paul@marilyn ~]$ ls bmw*rpm
bmw-release-1-1.fc10.noarch.rpm
[paul@marilyn ~]$ rpm -q bmw-release-1-1.fc10.noarch.rpm 
package bmw-release-1-1.fc10.noarch.rpm is not installed
[paul@marilyn ~]$ rpm -qp bmw-release-1-1.fc10.noarch.rpm 
bmw-release-1-1.fc10
[paul@marilyn ~]$ rpm -q rpm
rpm-4.4.2.3-18.el5
[paul@marilyn ~]$ cat /etc/redhat-release 
CentOS release 5.4 (Final)

Recommend CLOSED NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.