Bug 448424 - Amarok Forgets Output Device Selection / PulseAudio Missing SPDIF Out
Amarok Forgets Output Device Selection / PulseAudio Missing SPDIF Out
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 14:42 EDT by Bill Adams
Modified: 2008-07-09 16:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 16:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 376851 None None None Never

  None (edit)
Description Bill Adams 2008-05-26 14:42:04 EDT
My computer has snd-hda-intel hardware on the mobo with both 1/8" audio jacks
and optical out. I want most of the sounds to come out of the audio jacks
(STAC92xx Analog) but I want my music from Amarok to come out the optical cable
(STAC92xx Digital) which is connected to my stereo.


1) Where did system-config-sound go in F9? Previously (F8) I set the default
output device to Digital and lived with system beeps coming out of the stereo.


2) PulseAudio does not have STAC92xx Digital as an available output device to
which I can move Amarok. This was also true in F8: PulseAudio would only show
the default output device as selected in system-config-sound. Perhaps related to
https://bugzilla.redhat.com/show_bug.cgi?id=429729

If I change the default output for Music and Movies to digital (System ->
Preferences -> Hardware -> Sound), then the sound from Amarok comes out *both*
the Analog and Digital outputs (and the digital stream still does not appear in
PulseAudio).


3) In Amorok, select "xine" as the output system, "alsa" as the xine output
engine, "spdif:0" as the stereo output device (leaving all others output devices
at the default settings) and playback with a cross-fade of 500ms. Playback comes
through the optical connector for one song. When the next song plays, the stereo
output device reverts to "default" and comes back through PulseAudio.

3a) Change the mono output device to "spdif:0" and Amarok crashes (presumably
because it is trying to open a new output stream for the cross-fade and cannot).
Failure to open a stream should not cause Amarok to crash.

3b) Put both mono and stereo output on "spdif:0", change to having a 400ms gap
between songs (to allow for the spdif device to be closed and re-opened) and
output stays on the optical connector. (Same results with gap if mono output is
set to "default" -- so my guess is that problems only happen when Amarok tries
to open the same output device twice and that device is a hardware device that
can only be opened once.)


If I remember correctly, these same problems happened in F8 as well.


Ideally PulseAudio would recognize both the analog and digital output streams
and mix the stereo output so I can have cross-fading between songs. Also, this
setup means that I can only ever have one application (amarok in this case)
using the digital output.
Comment 1 Steven M. Parrish 2008-05-30 20:40:04 EDT
Checked upstream and could not find a matching bug.  Please file at bugs.kde.org
and add upstream info to this report.  We will monitor upstream report for
resolution.
Comment 2 Steven M. Parrish 2008-07-09 16:54:24 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.