Bug 448426 - [RHEL4/Evo28] depressed Send/Recieve button - evolution hung
[RHEL4/Evo28] depressed Send/Recieve button - evolution hung
Status: CLOSED DUPLICATE of bug 442644
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution28 (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Matthew Barnes
Depends On:
Blocks: 391511
  Show dependency treegraph
Reported: 2008-05-26 14:52 EDT by Alan Matsuoka
Modified: 2008-06-09 15:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-09 15:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
evolution28-2.8.0-59.el4-send.recieve.botton.stayed.depressed.evolution.hung.tar.gz (18.21 MB, application/x-gzip)
2008-05-26 14:52 EDT, Alan Matsuoka
no flags Details
sosreport (4.49 MB, application/x-bzip2)
2008-05-26 14:55 EDT, Alan Matsuoka
no flags Details
evolution28-2.8.0-59.el4-send.recieve.botton.stayed.depressed.evolution.hung.tar.gz (18.21 MB, application/x-gzip)
2008-06-09 14:07 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-05-26 14:52:10 EDT
Description of problem:

I discovered an email sitting in my outbox which should have been sent earlier
this morning. I selected the "Send/Recieve" button and evolution hung. The
button stayed depressed.

I captured gcores and BT's allround.

Previous to the find that I had an email in my outbox I had a SIGABRT on
exchange. I gcored that and saved it away.

Upon startup of this evolution session I had a password prompt for the Task
component. This is rare.

Please see uploaded archive:


Version-Release number of selected component (if applicable):

How reproducible:

happens when evolution-exchange crashes
Steps to Reproduce:
Actual results:

evolution hangs
Expected results:

evolution should probably pop up an error or warning dialogue after timing out.

Additional info:

Comments from SEG:

I'm not surprised that evolution was hanging after evolution-exchange crashed.

evolution was waiting on I/O from a non existent evolution-exchange. This is
really not a bug although it's my belief that evolution should either:

1) popup an error dialogue asking if you want to restart evolution
2) have some way of restarting the exchange connection

an application should not just hang because an error condition exists.
Comment 1 Alan Matsuoka 2008-05-26 14:52:15 EDT
Created attachment 306698 [details]
Comment 2 Alan Matsuoka 2008-05-26 14:55:42 EDT
Created attachment 306702 [details]
Comment 3 Matthew Barnes 2008-06-09 13:50:38 EDT
I believe evolution-exchange-storage has some capacity to restart itself if
spawned through bonobo-activation-server.  I think Nick tends to run the backend
processes directly under GDB, which may be related to why Evolution couldn't
recover.  Even still, I agree the behavior is not ideal.

Also, I can't seem to open the attached tarball.  It appears to be corrupted.
Comment 4 Matthew Barnes 2008-06-09 13:54:58 EDT
Setting status to NEEDINFO in hopes of a new tarball.
Comment 5 Alan Matsuoka 2008-06-09 14:07:15 EDT
Created attachment 308735 [details]
Comment 6 Matthew Barnes 2008-06-09 14:37:01 EDT
Still corrupt, I'm afraid.  Steve Beal indicated he couldn't open the attachment
in IssueTracker either.
Comment 7 Matthew Barnes 2008-06-09 15:01:05 EDT
Oops, spoke too soon.  The IT attachment is valid.

This is a duplicate of bug #442644.  We've also seen this backtrace in:

  IT #173389 / Bug #442644  and  IT #174905 / Bug #442631

*** This bug has been marked as a duplicate of 442644 ***

Note You need to log in before you can comment on or make changes to this bug.