Bug 448443 - GCC: will not compile any programs
GCC: will not compile any programs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 18:16 EDT by Jason Bogstie
Modified: 2008-05-28 20:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 20:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Bogstie 2008-05-26 18:16:54 EDT
Description of problem: Whenever I attempt to compile a program from source, GCC
gives me an error and will not continue.


Version-Release number of selected component (if applicable):


How reproducible: This occurs any time I attempt to compile an application from
source.



Additional info:

Console gives me this when I attempt to compile wine, as an example:

gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7412: Warning: end of file not at end of a line; newline inserted
{standard input}:7745: Error: unknown pseudo-op: `.l'
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [menu.o] Error 1
make[2]: Leaving directory `/home/jbogstie/Desktop/wine-1.0-rc2/dlls/user32/tests'
make[1]: *** [user32/tests] Error 2
make[1]: Leaving directory `/home/jbogstie/Desktop/wine-1.0-rc2/dlls'
make: *** [dlls] Error 2

Compilation failed, aborting install.
Comment 1 Jason Bogstie 2008-05-28 20:26:39 EDT
I have tried uninstalling and reinstalling GCC and the same problem occurs.
Comment 2 Jason Bogstie 2008-05-28 20:39:54 EDT
After searching the internet to no end I discovered this same bug posted
somewhere else, It was recommend that your run this command since this is a
known issue in FC9



ulimit -s unlimited



After running this command I can confirm that the issue is resolved.

Note You need to log in before you can comment on or make changes to this bug.