Bug 448476 - Missing profile environment after login
Missing profile environment after login
Status: CLOSED DUPLICATE of bug 458839
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 03:22 EDT by Enrico Scholz
Modified: 2014-01-12 19:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 10:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2008-05-27 03:22:23 EDT
Description of problem:

F-9 does not seem to execute ~/.bash_profile anymore. E.g.

| $ ssh `hostname` set
| KRB5CCNAME=FILE:/tmp/krb5cc_1000_2TT2cj
| LOGNAME=ensc
| MACHTYPE=x86_64-redhat-linux-gnu
| ...
| PATH=/usr/local/bin:/bin:/usr/bin
| ...
| _=EMACS
| prefix=-sheridan.bigo.ensc.de
| [ensc@sheridan /]$ 

Doing the same for a F-8 host (with same $HOME), I get essential variables
like $LANG and $http_proxy which are defined by /etc/profile.d:

| $ ssh fc5 set
| KRB5CCNAME=FILE:/tmp/krb5cc_1000_3DD1Vf
| LANG=de_DE.UTF-8
| LC_COLLATE=C
| LESSOPEN='|/usr/bin/lesspipe.sh %s'
| LOGNAME=ensc
| MACHTYPE=i386-redhat-linux-gnu
| ...
| PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin
| ...
| _=EMACS
| consoletype=serial
| ftp_proxy=http://www-cache:3128/
| http_proxy=http://www-cache:3128/
| https_proxy=http://www-cache:3128/
| no_proxy=bigo.ensc.de,127.0.0.1,localhost,localdomain
| prefix=-fc5.bigo.ensc.de
| [ensc@sheridan /]$ 


Similarly for an interactive login:

| $ echo set  | ssh `hostname`
| KRB5CCNAME=FILE:/tmp/krb5cc_1000_o9Ayck
| LANG=de_DE.UTF-8
| LC_COLLATE=C
| LESSOPEN='|/usr/bin/lesspipe.sh %s'
| LOGNAME=ensc
| MACHTYPE=x86_64-redhat-linux-gnu
| ...
|
PATH=/usr/lib64/qt-3.3/bin:/usr/kerberos/bin:/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/home/ensc/bin



This affects login through kdm into a xfce4 session too; there, the
"Start application" function (A-F2) uses a $PATH without $HOME/bin
(which is added by ~/.bash_profile).

Dunno whether 'setup' is the right component, perhaps it is bash.



Version-Release number of selected component (if applicable):

bash-3.2-22.fc9.x86_64
setup-2.6.14-1.fc9.noarch


How reproducible:

100%
Comment 1 Roman Rakus 2008-11-05 10:04:54 EST
Definitely bash.

*** This bug has been marked as a duplicate of bug 458839 ***

Note You need to log in before you can comment on or make changes to this bug.