Bug 448478 - traceback in "suid"
traceback in "suid"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sectool (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 03:23 EDT by Miloslav Trmač
Modified: 2008-07-03 23:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.8.0-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 23:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2008-05-27 03:23:00 EDT
Description of problem:
The following traceback appeared on the terminal:

stderr from suid: Traceback (most recent call last):
  File "/usr/share/sectool/tests/suid.py", line 114, in <module>
    main()
  File "/usr/share/sectool/tests/suid.py", line 64, in main
    for gen in [ os.walk(dir) for dir in testenv['PATH'].split(':') ]:
  File "/usr/lib/python2.5/UserDict.py", line 22, in __getitem__

Version-Release number of selected component (if applicable):
sectool-0.7.4-1.i386

How reproducible:
This appeared once while running all tests from different levels from the GUI. 
I couldn't reproduce it since.
Comment 1 Jakub Hrozek 2008-05-27 12:25:25 EDT
I can't reproduce the bug myself either, I've also checked the code of the 
suid test and the only UserDict-derived class that is used is the 'testenv' 
variable which is just an alias for os.environ (from os import environ as 
testenv). So, I'm really puzzled about what's going on..

If you encounter this error again, please holler..
Comment 2 Fedora Update System 2008-07-03 06:33:08 EDT
sectool-0.8.0-1.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-07-03 23:39:44 EDT
sectool-0.8.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.