Bug 448480 - /etc/profile.d/alc_env.csh causes MANPATH complaints
/etc/profile.d/alc_env.csh causes MANPATH complaints
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alliance (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 04:05 EDT by Pekka Pietikäinen
Modified: 2008-06-03 03:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0-16.20070718snap.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 03:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2008-05-27 04:05:54 EDT
Description of problem:

[user@somewhere ~]$ tcsh
MANPATH: Undefined variable.

Version-Release number of selected component (if applicable):

alliance-libs-5.0-13.20070718snap.fc9.i386

The offending part in the script is 
setenv MANPATH "${MANPATH}:${ALLIANCE_TOP}/man"

which tcsh doesn't like when MANPATH isn't defined.
Comment 1 Chitlesh GOORAH 2008-05-27 14:10:44 EDT
I have already pushed a new release for alliance correcting this bug, yesterday.

alliance-5.0-15.20070718snap.fc9.i386

If you would like, you can test the rpms on
http://koji.fedoraproject.org/koji/buildinfo?buildID=50557

If it fixes your bug, we can close this bug.
Comment 2 Pekka Pietikäinen 2008-05-27 14:51:49 EDT
[pp@it-pc37 profile.d]# source alc_env.csh
Bad : modifier in $ ($).

   setenv PATH "$PATH:${ALLIANCE_TOP}/bin:"
->
   setenv PATH "${PATH}:${ALLIANCE_TOP}/bin:"

and the same to LD_LIBRARY_PATH should do the trick.
Comment 3 Chitlesh GOORAH 2008-05-30 13:30:42 EDT

*** This bug has been marked as a duplicate of 449062 ***
Comment 4 Fedora Update System 2008-06-02 16:23:09 EDT
alliance-5.0-16.20070718snap.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-06-03 03:34:37 EDT
alliance-5.0-16.20070718snap.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.