Bug 448482 - When asking for confirmation yum does not accept 'n' or 'N' when LANG ist set to de_DE.UTF-8
When asking for confirmation yum does not accept 'n' or 'N' when LANG ist set...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 04:24 EDT by Christoph Maser
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 10:08:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Maser 2008-05-27 04:24:04 EDT
When you use yum interactively and LANG is set to de_DE.UTF-8 it does not accept
'n' or 'N' as input for final confirmation. Using enter hower selects "No" and
cancels the extion. If i set LANG to C "n" is accepted as input and cancels the
action.  Sample output:

[cmr@HUB8071NC4 ~]$ sudo yum install postgresql
Geladene Plugins: priorities, refresh-packagekit
Reduziere Fedora 9 - i386 - Updates nur zum Einbeziehen der Pakete
Fertig
Reduziere Fedora 9 - i386 nur zum Einbeziehen der Pakete
Fertig
4 packages excluded due to repository priority protections
Einrichten des Installationsprozess
Analysiere Installationsargumente des Pakets
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket postgresql.x86_64 0:8.3.1-1.fc9 gesetzt um aktualisiert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

=============================================================================
 Paket                   Arch       Version          Repository        Größe
=============================================================================
Installieren:
 postgresql              x86_64     8.3.1-1.fc9      fedora            3.4 M

Transaktionszusammenfassung
=============================================================================
Installieren        1 Pakete(e)         
Aktualisieren       0 Pakete(e)         
Enfernen          0 Paket(e)         

Gesamte Downloadgröße: 3.4 M
Ist dies richtig? [j/N] :n                             <- not accepted
Ist dies richtig? [j/N] :N                             <- not accepted
Ist dies richtig? [j/N] :                              <- pressed return
Beende auf Benutzer-Befehl hin
Komplett!
Comment 1 Seth Vidal 2008-05-27 10:08:22 EDT
Fixed in yum 3.2.16-2 in updates-testing now.

Note You need to log in before you can comment on or make changes to this bug.