Bug 448483 - documentation images corrupt by SPEC
documentation images corrupt by SPEC
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bibus (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 04:34 EDT by Nicolas Thierry-Mieg
Modified: 2008-06-13 02:10 EDT (History)
0 users

See Also:
Fixed In Version: 1.4.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 02:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Thierry-Mieg 2008-05-27 04:34:49 EDT
Description of problem:
bibus has a bunch of PNG files that are linked from the html documentation, in
SOURCES/bibus-1.4.1/Docs/html/en/setup
For example setup_firststart.png

Those images are OK in the tar.gz source archive, but they become corrupt when
the rpm is built.

As a result, the locally installed documentation is broken (no images).


Version-Release number of selected component (if applicable):

bibus-1.4.1-4.fc8.noarch.rpm


How reproducible:
100%

Steps to Reproduce:
1. install rpm
2. cd /usr/share/doc/bibus-1.4.1/html/en/setup/
3.(just one example) file setup_firststart.png
  
Actual results:
setup_firststart.png: PNG image data, CORRUPTED,


Expected results:
setup_firststart.png: PNG image data, 453 x 404, 8-bit/color RGB, non-interlaced

Additional info:

The problem is this line in the SPEC:

##  fix line endings
find Docs -type f -exec sed -i 's/\r//' {} 2>/dev/null ';'

not sure how to fix it, I don't sed, but as always you should at least specify
the regexp better (eg s/\r\n$/\n/ in perl).
Maybe you could also specify your find target more precisely, with -name, but I
don't know what it is you are trying to convert.
Comment 1 Nicolas Thierry-Mieg 2008-05-27 05:55:02 EDT
I couldn't get the sed regexp syntax right to only substitute \r\n$, but further
examination shows that the "line ending" problem seems to only affect some xml
and html files.
So, the bug can be fixed by only using -name *ml
This won't be very robust (will break if future versions have binary files named
*ml, or if DOS text files not ending with ml are added), but for the current
version this seems to work:
replace the bad SPEC line by
find Docs -type f -name *ml -exec sed -i 's/\r//' {} 2>/dev/null ';'
Comment 2 Alex Lancaster 2008-06-03 05:09:11 EDT
Sorry I haven't had time to address this bug yet.  I may have some time later
this week to push out a new update.
Comment 3 Fedora Update System 2008-06-10 06:58:23 EDT
bibus-1.4.3-1.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-10 06:59:49 EDT
bibus-1.4.3-1.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-06-11 00:34:04 EDT
bibus-1.4.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5181
Comment 6 Fedora Update System 2008-06-12 22:18:45 EDT
bibus-1.4.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-06-12 22:19:01 EDT
bibus-1.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.