Bug 44849 - xmms SRPM needs build dependency on gnome-core-devel
xmms SRPM needs build dependency on gnome-core-devel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-18 09:55 EDT by Jay Turner
Modified: 2015-01-07 18:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 14:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build output for xmms (170.11 KB, text/plain)
2001-07-23 14:45 EDT, Glen Foster
no flags Details

  None (edit)
Description Glen Foster 2001-06-18 09:55:17 EDT
Description of Problem: with the 7.1 product, you cannot build the xmms
SRPM without having gnome-core-devel installed.   But, if "rpm -ba
/usr/src/redhat/SPECS/xmms*spec" is executed, you do NOT get an error from
rpm about missing/unsatisfied build dependencies.  If you install the
gnome-core-devel rpm, the xmms SRPM builds without problems.

How Reproducible: Always

Steps to Reproduce:
  1. rpm -e gnome-core-devel
  2. rpm -Uvh <tree-path>/SRPMS/xmms*.src.rpm
  3. rpm -ba /usr/src/redhat/SPECS/xmms*spec
  4. rpm -Uvh <tree-path>/RedHat/RPMS/gnome-core-devel*
  5. rpm -ba /usr/src/redhat/SPECS/xmms*spec

Actual Results:
first 3 steps result in a failure WITHOUT a build-requires error from rpm
next 2 steps build the SRPM without fail

Expected Results:  I would expect an rpm error message to be written to
stderr informing me the xmms SRPM cannot be built without installing the
gnome-core-devel RPM.


Additional Information:
Comment 1 Helge Deller 2001-06-18 10:50:28 EDT
fixed in xmms-1.2.4-17.src.rpm
Comment 2 Glen Foster 2001-07-23 14:44:15 EDT
Sorry, I tested this incompletely last time, and I have recently discovered
more missing build-dependencies.  In addition to the current set of build
dependenceies, the xmms SRPM also needs build dependencies for:

	gnome-libs-devel

IN ADDITION(!), it looks like there are other optional packages that may or may
not be necessary for build dependencies.  Judging from the build output, it
appears there are possible requirements for Mesa-devel, libogg-devel, and
libxml-devel.  I'll attach the build output to this defect after this message is
posted.

Regardless, the gnome-libs-devel dependency must be present for this package to
build; otherwise the build fails with a rather cryptic message...
Comment 3 Glen Foster 2001-07-23 14:45:03 EDT
Created attachment 24632 [details]
Build output for xmms
Comment 4 Bill Nottingham 2001-07-23 14:59:51 EDT
Fixed in 1.2.5-5. The other (libogg, libvorbis, Mesa) are for optional plugins.

Note You need to log in before you can comment on or make changes to this bug.