Bug 448500 - RFE: limitation info about NIC and VBD in virtualization cookbook
RFE: limitation info about NIC and VBD in virtualization cookbook
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Christopher Curran
Don Domingo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 05:54 EDT by Kazuo Moriwaka
Modified: 2009-09-02 00:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 00:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Christopher Curran 2009-05-05 21:06:33 EDT
Bill,

Can you confirm this limit? I cannot find this limit mentioned in the RHEL product limits (http://intranet.corp.redhat.com/ic/intranet/RHELProductLimits.html) or the release notes.

Chris
Comment 2 Bill Burns 2009-05-07 15:04:24 EDT
The limit of 4 NICs was removed and not replaced! There is no hardwired limit. There are a minimum of 4 NICs allowed but more if the host has more network interfaces (in other words the code now allows all physical NICs to be used.
Chris Lalancette can expound on the vbd side.
Comment 3 Chris Lalancette 2009-05-08 08:56:29 EDT
Well, it really depends on what you are talking about, including with the NIC stuff.

For the NICs, in 5.2 and earlier, there was a limitation of 4 *physical* NICs that the dom0 could use, and thus hand out to guests.  We removed that limitation in 5.3.  There has never been any documented limit about *how many* guests you could hook to a single dom0 NIC, although I don't know what's been tested.  The other limitation is that for a single PV or PV-on-HVM guest, you can only hook up 15 virtual interfaces.  More than that causes some sort of problem (although this is probably just a bug, not an inherent limitation).

For the block side, things are simpler when you are talking about dom0.  For the most part, any block device that the normal RHEL-5 kernel supports will be supported by the Xen kernel, although there are exceptions.  For guests, things are more complicated.

For a PV or PV-on-HVM guest, prior to 5.2, the maximum number of disks you could hook up was 16.  In 5.3 and later, the maximum number of disks is 256.  However, note that there are other limitations here.  In particular, when you are talking about file-backed disks, for PV we use the tap:aio driver.  That driver only allows a total of 100 disks in the entire machine.  If, instead, you use partitions or LVM devices (i.e. the "phys" driver), then there is no limitation that I know about.

For pure HVM guests, it depends on whether you are using the IDE or the SCSI driver.  For the IDE driver, the maximum is 4 disks.  For the SCSI driver, I don't actually know.

So basically, there are limitations both in the frontends (i.e. in the guests), and in the backends (i.e. in the dom0), and those limitations are sometimes different.  Let me know if you have questions on this, because it is kind of complicated, and I don't know if I did a good job explaining.

Chris Lalancette
Comment 4 Christopher Curran 2009-05-12 21:53:22 EDT
Thanks Chris. 

This explains things nicely. Because the guide covers all versions I better document the 4 NIC limit as applying to >=5.2. If the limit is changing again from 5.3 to 5.4 I will need to cover that too. 

I'll mark it need info again for review once the content is in the book.

Chris

Note You need to log in before you can comment on or make changes to this bug.