Bug 448501 - Anaconda does not use excludepkgs in kickstart repo command
Anaconda does not use excludepkgs in kickstart repo command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 05:57 EDT by Jasper Siepkes
Modified: 2009-02-16 15:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:32:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper Siepkes 2008-05-27 05:57:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080418 Ubuntu/7.10 (gutsy) Firefox/2.0.0.14

Description of problem:
When you use a kickstart file with additional yum repositories added to it with the repo command (as described in http://fedoraproject.org/wiki/Anaconda/Kickstart), the excludepkgs option is not used by anaconda.

The excludepkgs option is also omitted from the /root/anaconda-ks.cfg file after a kickstart install.

It could be that I'm just being daft :-) , but if I look at the anaconda source I can't see any evidence that the repo options "excludepkgs", "includepkgs" and "priority" as specified in http://fedoraproject.org/wiki/Anaconda/Kickstart actually exist as valid options.

Version-Release number of selected component (if applicable):
11.4.0.82

How reproducible:
Always


Steps to Reproduce:
1. Create a kickstart file and add an additional yum repository and specify some packages to be excluded. For example: 
repo --name=Update --baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/9/i386/ --excludepkgs=kernel
2. Perform a kickstart install with anaconda with the kickstart file just created.

Actual Results:
The kernel package from the update repo is used.

Expected Results:
I would expect that the kernel package from the update repo is not used and that the kernel package from another repo is used.

Additional info:
Comment 1 Chris Lumens 2008-05-28 17:28:58 EDT
Oops, that's because --excludepkgs and --includepkgs was only ever added for
distribution build tools.  The next build of anaconda should support this,
though I have not yet tested it for correctness.  If you have the capability to
test out rawhide, please give it a spin.

Note You need to log in before you can comment on or make changes to this bug.